# CVE-2025-59042: PyInstaller has local privilege escalation vulnerability

> An attacker can inject malicious Python code into PyInstaller-frozen applications via path manipulation, leading to arbitrary code execution and potential privilege escalation.

- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 10 Sep 2025
- **Also known as:** GHSA-p2xp-xx3r-mffc, OESA-2025-2322, OESA-2025-2323, OESA-2025-2324, PYSEC-2026-1813

## What is CVE-2025-59042?

CVE-2025-59042 is a high-severity code injection vulnerability in pyinstaller, published on 9 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PyInstaller bundles a Python application and all its dependencies into a single package. Due to a special entry being appended to `sys.path` during the bootstrap process of a PyInstaller-frozen application, and due to the bootstrap script attempting to load an optional module for bytecode decryption while this entry is still present in `sys.path`, an application built with PyInstaller < 6.0.0 may be tricked by an unprivileged attacker into executing arbitrary python code when **all** of the following conditions are met. First, the application is built with PyInstaller < 6.0.0; both onedir and onefile mode are affected. Second, the optional bytecode encryption code feature was not enabled during the application build. Third, the attacker can create files/directories in the same directory where the executable is located. Fourth, the filesystem supports creation of files/directories that contain `?` in their name (i.e., non-Windows systems). Fifth, the attacker is able to determine the offset at which the PYZ archive is embedded in the executable. The attacker can create a directory (or a zip archive) next to the executable, with the name that matches the format used by PyInstaller's bootloader to transmit information about the location of PYZ archive to the bootstrap script. If this directory (or zip archive) contains a python module whose name matches the name used by the optional bytecode encryption feature, this module will be loaded and executed by the bootstrap script (in the absence of the real, built-in module that is available when the bytecode-encryption feature is enabled). This results in arbitrary code execution that requires no modification of the executable itself. If the executable is running with elevated privileges (for example, due to having the `setuid` bit set), the code in the injected module is also executed with the said elevated privileges, resulting in a local privilege escalation. PyInstaller 6.0.0 (f5adf291c8b832d5aff7632844f7e3ddf7ad4923) removed support for bytecode encryption; this effectively removes the described attack vector, due to the bootstrap script not attempting to load the optional module for bytecode-decryption anymore. PyInstaller 6.10.0 (cfd60b510f95f92cb81fc42735c399bb781a4739) reworked the bootstrap process to avoid (ab)using `sys.path` for transmitting location of the PYZ archive, which further eliminates the possibility of described injection procedure. If upgrading PyInstaller is not feasible, this issue can be worked around by ensuring proper permissions on directories containing security-sensitive executables (i.e., executables with `setuid` bit set) should mitigate the issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-59042?

3 open source packages ship an affected version, including pyinstaller.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyinstaller` | PyPI | All versions | 6.0.0 |
| `pyinstaller` | PyPI | All versions | 6.0.0 |
| `pyinstaller` | PyPI | All versions | 6.0.0 |

## How do I fix CVE-2025-59042?

Upgrade pyinstaller to 6.0.0 or later.

## Is CVE-2025-59042 being exploited?

There is no known exploitation of CVE-2025-59042 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59042 and fix it if it is affected.

What it is: CVE-2025-59042 is a high-severity code injection vulnerability in pyinstaller, published on 9 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59042 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyinstaller (PyPI): affected all versions; fixed in 6.0.0
- pyinstaller (PyPI): affected all versions; fixed in 6.0.0
- pyinstaller (PyPI): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59042/ (Markdown: https://insights.sbomify.com/CVE-2025-59042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59042
- OSV: https://osv.dev/vulnerability/CVE-2025-59042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59042/
Summaries are generated and may contain mistakes; the official description above is the record.
