# CVE-2025-59043: OpenBao vulnerable to denial of service via malicious JSON request processing

> Unauthenticated attackers can cause out-of-memory crashes in OpenBao by sending crafted JSON payloads that bypass size limits.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2025
- **Updated:** 17 Oct 2025
- **Also known as:** BIT-openbao-2025-59043, GHSA-g46h-2rq9-gw5m, GO-2025-4039

## What is CVE-2025-59043?

CVE-2025-59043 is a high-severity denial of service vulnerability in openbao, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. In OpenBao versions prior to 2.4.1, JSON objects after decoding may use significantly more memory than their serialized version. It is possible to craft a JSON payload to maximize the factor between serialized memory usage and deserialized memory usage, similar to a zip bomb, with factors reaching approximately 35. This can be used to circumvent the max_request_size configuration parameter which is intended to protect against denial of service attacks. The request body is parsed into a map very early in the request handling chain before authentication, which means an unauthenticated attacker can send a specifically crafted JSON object and cause an out-of-memory crash. Additionally, for requests with large numbers of strings, the audit subsystem can consume large quantities of CPU. The vulnerability is fixed in version 2.4.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-59043?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | None |
| `github.com/openbao/openbao` | Go | All versions | 2.4.1 |
| `github.com/openbao/openbao` | Go | All versions | 2.4.1 |
| `openbao` | Bitnami | All versions | 2.4.1 |

Products: Openbao Openbao.

## How do I fix CVE-2025-59043?

Upgrade github.com/openbao/openbao to 2.4.1 or later.

## Is CVE-2025-59043 being exploited?

There is no known exploitation of CVE-2025-59043 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-54996](https://insights.sbomify.com/CVE-2025-54996/): OpenBao Root Namespace Operator May Elevate Token Privileges (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59043 and fix it if it is affected.

What it is: CVE-2025-59043 is a high-severity denial of service vulnerability in openbao, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59043 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; no fix listed
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.4.1
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.4.1
- openbao (Bitnami): affected all versions; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59043/ (Markdown: https://insights.sbomify.com/CVE-2025-59043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59043
- OSV: https://osv.dev/vulnerability/CVE-2025-59043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59043/
Summaries are generated and may contain mistakes; the official description above is the record.
