{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-59045 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-59045 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59045 is a high-severity denial of service vulnerability in stalwartlabs stalwart, published on 10 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59045 and fix it if it is affected.\n\nWhat it is: CVE-2025-59045 is a high-severity denial of service vulnerability in stalwartlabs stalwart, published on 10 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59045 in the wild and no public exploit code.\n\nAffected product: stalwartlabs stalwart. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59045/ (Markdown: https://insights.sbomify.com/CVE-2025-59045/index.md)","id":"CVE-2025-59045","markdown":"https://insights.sbomify.com/CVE-2025-59045/index.md","name":"CVE-2025-59045","record":{"aliases":["GHSA-xv4r-q6gr-6pfg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mail and collaboration server","requires_auth":"low_privilege","summary":"Authenticated attackers can crash the Stalwart mail server by triggering unbounded memory consumption via CalDAV recurring event expansion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Stalwart is a mail and collaboration server. Starting in version 0.12.0 and prior to version 0.13.3, a memory exhaustion vulnerability exists in Stalwart's CalDAV implementation that allows authenticated attackers to cause denial-of-service by triggering unbounded memory consumption through recurring event expansion. An authenticated attacker can crash the Stalwart server by creating recurring events with large payloads and triggering their expansion through CalDAV REPORT requests. A single malicious request expanding 300 events with 1000-character descriptions can consume up to 2 GB of memory. The vulnerability exists in the `ArchivedCalendarEventData.expand` function, which processes CalDAV `REPORT` requests with event expansion. When a client requests recurring events in their expanded form using the `\u003cC:expand\u003e` element, the server stores all expanded event instances in memory without enforcing size limits. Users should upgrade to Stalwart version 0.13.3 or later to receive a fix. If immediate upgrading is not possible, implement memory limits at the container/system level; monitor server memory usage for unusual spikes; consider rate limiting CalDAV REPORT requests; and restrict CalDAV access to trusted users only.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Stalwart vulnerable to Memory Exhaustion via CalDAV Event Expansion","id":"CVE-2025-59045","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"interactive-git-checkout has Command Injection vulnerability","id":"CVE-2025-59046"},"packages":[],"prev":{"headline":"Himmelblau vulnerable to GID collision via group name-derived mapping (privilege escalation)","id":"CVE-2025-59044"},"products":["stalwart"],"published":"2025-09-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-11","vendors":["stalwartlabs"]},"summary":"Authenticated attackers can crash the Stalwart mail server by triggering unbounded memory consumption via CalDAV recurring event expansion.","url":"https://insights.sbomify.com/CVE-2025-59045/"}