CVE-2025-59047 matrix-sdk-base has panic in the `RoomMember::normalized_power_level()` method

Low 2.7 Published Updated

A panic in the Matrix SDK base library allows denial of service when processing specific power levels, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59047?

CVE-2025-59047 is a low-severity denial of service vulnerability in matrix-org matrix-rust-sdk, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

matrix-sdk-base is the base component to build a Matrix client library. In matrix-sdk-base before 0.14.1, calling the `RoomMember::normalized_power_level()` method can cause a panic if a room member has a power level of `Int::Min`. The issue is fixed in matrix-sdk-base 0.14.1. The affected method isn’t used internally, so avoiding calling `RoomMember::normalized_power_level()` prevents the panic.

Weakness: CWE-682

Which versions are affected by CVE-2025-59047?

4 open source packages ship an affected version, including matrix-sdk-base.

PackageAffectedFixed in
matrix-sdk-base crates.ioAll versions0.14.1
matrix-sdk-base crates.ioAll versions0.14.1
matrix-sdk-base crates.ioFrom 0.0.0-00.14.1
matrix-sdk-base crates.ioFrom 0.0.0-00.14.1

How do I fix CVE-2025-59047?

Upgrade matrix-sdk-base to 0.14.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-59047 being exploited?

There is no known exploitation of CVE-2025-59047 in the wild and no public exploit code.

Sources

Also known as GHSA-qhj8-q5r6-8q6j, RUSTSEC-2025-0000, RUSTSEC-2025-0065.

Is CVE-2025-59047 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free