{"answers":{"affected":"4 open source packages ship an affected version, including matrix-sdk-base.","exploited":"There is no known exploitation of CVE-2025-59047 in the wild and no public exploit code.","fix":"Upgrade matrix-sdk-base to 0.14.1 or later.","what":"CVE-2025-59047 is a low-severity denial of service vulnerability in matrix-org matrix-rust-sdk, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59047 and fix it if it is affected.\n\nWhat it is: CVE-2025-59047 is a low-severity denial of service vulnerability in matrix-org matrix-rust-sdk, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59047 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-sdk-base (crates.io): affected all versions; fixed in 0.14.1\n- matrix-sdk-base (crates.io): affected all versions; fixed in 0.14.1\n- matrix-sdk-base (crates.io): affected from 0.0.0-0; fixed in 0.14.1\n- matrix-sdk-base (crates.io): affected from 0.0.0-0; fixed in 0.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59047/ (Markdown: https://insights.sbomify.com/CVE-2025-59047/index.md)","id":"CVE-2025-59047","markdown":"https://insights.sbomify.com/CVE-2025-59047/index.md","name":"CVE-2025-59047","record":{"aliases":["GHSA-qhj8-q5r6-8q6j","RUSTSEC-2025-0000","RUSTSEC-2025-0065"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Matrix SDK library","requires_auth":"none","summary":"A panic in the Matrix SDK base library allows denial of service when processing specific power levels, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-682","name":"Incorrect Calculation"}],"description":"matrix-sdk-base is the base component to build a Matrix client library. In matrix-sdk-base before 0.14.1, calling the `RoomMember::normalized_power_level()` method can cause a panic if a room member has a power level of `Int::Min`. The issue is fixed in matrix-sdk-base 0.14.1. The affected method isn’t used internally, so avoiding calling `RoomMember::normalized_power_level()` prevents the panic.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"matrix-sdk-base has panic in the `RoomMember::normalized_power_level()` method","id":"CVE-2025-59047","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"OpenBao AWS Plugin Vulnerable to Cross-Account IAM Role Impersonation in AWS Auth Method","id":"CVE-2025-59048"},"packages":[{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0"],"last_affected":[],"package":"matrix-sdk-base","purl":null,"source":"GHSA-qhj8-q5r6-8q6j"},{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0"],"last_affected":[],"package":"matrix-sdk-base","purl":"pkg:cargo/matrix-sdk-base","source":"GHSA-qhj8-q5r6-8q6j"},{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0.0.0-0"],"last_affected":[],"package":"matrix-sdk-base","purl":"pkg:cargo/matrix-sdk-base","source":"RUSTSEC-2025-0000"},{"ecosystem":"crates.io","fixed":["0.14.1"],"introduced":["0.0.0-0"],"last_affected":[],"package":"matrix-sdk-base","purl":"pkg:cargo/matrix-sdk-base","source":"RUSTSEC-2025-0065"}],"prev":{"headline":"interactive-git-checkout has Command Injection vulnerability","id":"CVE-2025-59046"},"products":["matrix-rust-sdk"],"published":"2025-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-11","vendors":["matrix-org"]},"summary":"A panic in the Matrix SDK base library allows denial of service when processing specific power levels, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2025-59047/"}