# CVE-2025-59047: matrix-sdk-base has panic in the `RoomMember::normalized_power_level()` method

> A panic in the Matrix SDK base library allows denial of service when processing specific power levels, requiring an upgrade to fix.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2025
- **Updated:** 11 Sep 2025
- **Also known as:** GHSA-qhj8-q5r6-8q6j, RUSTSEC-2025-0000, RUSTSEC-2025-0065

## What is CVE-2025-59047?

CVE-2025-59047 is a low-severity denial of service vulnerability in matrix-org matrix-rust-sdk, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

matrix-sdk-base is the base component to build a Matrix client library. In matrix-sdk-base before 0.14.1, calling the `RoomMember::normalized_power_level()` method can cause a panic if a room member has a power level of `Int::Min`. The issue is fixed in matrix-sdk-base 0.14.1. The affected method isn’t used internally, so avoiding calling `RoomMember::normalized_power_level()` prevents the panic.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2025-59047?

4 open source packages ship an affected version, including matrix-sdk-base.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-sdk-base` | crates.io | All versions | 0.14.1 |
| `matrix-sdk-base` | crates.io | All versions | 0.14.1 |
| `matrix-sdk-base` | crates.io | From 0.0.0-0 | 0.14.1 |
| `matrix-sdk-base` | crates.io | From 0.0.0-0 | 0.14.1 |

## How do I fix CVE-2025-59047?

Upgrade matrix-sdk-base to 0.14.1 or later.

## Is CVE-2025-59047 being exploited?

There is no known exploitation of CVE-2025-59047 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59047 and fix it if it is affected.

What it is: CVE-2025-59047 is a low-severity denial of service vulnerability in matrix-org matrix-rust-sdk, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59047 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-sdk-base (crates.io): affected all versions; fixed in 0.14.1
- matrix-sdk-base (crates.io): affected all versions; fixed in 0.14.1
- matrix-sdk-base (crates.io): affected from 0.0.0-0; fixed in 0.14.1
- matrix-sdk-base (crates.io): affected from 0.0.0-0; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59047/ (Markdown: https://insights.sbomify.com/CVE-2025-59047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59047
- OSV: https://osv.dev/vulnerability/CVE-2025-59047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59047/
Summaries are generated and may contain mistakes; the official description above is the record.
