{"answers":{"affected":"3 open source packages ship an affected version, including github.com/openbao/openbao-plugins. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59048 in the wild and no public exploit code.","fix":"Upgrade github.com/openbao/openbao-plugins to 0.1.1 or later.","what":"CVE-2025-59048 is a high-severity authentication bypass vulnerability in openbao-plugins, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59048 and fix it if it is affected.\n\nWhat it is: CVE-2025-59048 is a high-severity authentication bypass vulnerability in openbao-plugins, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/openbao/openbao-plugins (Go): affected all versions; no fix listed\n- github.com/openbao/openbao-plugins (Go): affected all versions; fixed in 0.1.1\n- github.com/openbao/openbao-plugins (Go): affected all versions; fixed in 0.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59048/ (Markdown: https://insights.sbomify.com/CVE-2025-59048/index.md)","id":"CVE-2025-59048","markdown":"https://insights.sbomify.com/CVE-2025-59048/index.md","name":"CVE-2025-59048","record":{"aliases":["GHSA-jp7h-4f3c-9rc7","GO-2025-4067"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenBao AWS plugin","requires_auth":"low_privilege","summary":"Attackers can impersonate trusted IAM roles from untrusted accounts to gain unauthorized access to OpenBao secrets in multi-account AWS environments.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"aws_plugin","vendor":"openbao"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-694","name":"Use of Multiple Resources with Duplicate Identifier"}],"description":"OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin. A workaround for this issue involves guaranteeing that IAM role names are unique across all AWS accounts that could potentially interact with your OpenBao environment, and to audit for any duplicate IAM roles.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenBao AWS Plugin Vulnerable to Cross-Account IAM Role Impersonation in AWS Auth Method","id":"CVE-2025-59048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Mockoon has a Path Traversal and LFI in the static file serving endpoint","id":"CVE-2025-59049"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/openbao/openbao-plugins","purl":"pkg:golang/github.com/openbao/openbao-plugins","source":"GO-2025-4067"},{"ecosystem":"Go","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"github.com/openbao/openbao-plugins","purl":null,"source":"GHSA-jp7h-4f3c-9rc7"},{"ecosystem":"Go","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"github.com/openbao/openbao-plugins","purl":"pkg:golang/github.com/openbao/openbao-plugins","source":"GHSA-jp7h-4f3c-9rc7"}],"prev":{"headline":"matrix-sdk-base has panic in the `RoomMember::normalized_power_level()` method","id":"CVE-2025-59047"},"products":["openbao-plugins"],"published":"2025-10-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-23","vendors":["openbao"]},"summary":"Attackers can impersonate trusted IAM roles from untrusted accounts to gain unauthorized access to OpenBao secrets in multi-account AWS environments.","url":"https://insights.sbomify.com/CVE-2025-59048/"}