# CVE-2025-59048: OpenBao AWS Plugin Vulnerable to Cross-Account IAM Role Impersonation in AWS Auth Method

> Attackers can impersonate trusted IAM roles from untrusted accounts to gain unauthorized access to OpenBao secrets in multi-account AWS environments.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** GHSA-jp7h-4f3c-9rc7, GO-2025-4067

## What is CVE-2025-59048?

CVE-2025-59048 is a high-severity authentication bypass vulnerability in openbao-plugins, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin. A workaround for this issue involves guaranteeing that IAM role names are unique across all AWS accounts that could potentially interact with your OpenBao environment, and to audit for any duplicate IAM roles.

Weakness: CWE-863 (Incorrect Authorization), CWE-694 (Use of Multiple Resources with Duplicate Identifier)

## Which versions are affected by CVE-2025-59048?

3 open source packages ship an affected version, including github.com/openbao/openbao-plugins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao-plugins` | Go | All versions | None |
| `github.com/openbao/openbao-plugins` | Go | All versions | 0.1.1 |
| `github.com/openbao/openbao-plugins` | Go | All versions | 0.1.1 |

Products: Openbao Aws Plugin.

## How do I fix CVE-2025-59048?

Upgrade github.com/openbao/openbao-plugins to 0.1.1 or later.

## Is CVE-2025-59048 being exploited?

There is no known exploitation of CVE-2025-59048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59048 and fix it if it is affected.

What it is: CVE-2025-59048 is a high-severity authentication bypass vulnerability in openbao-plugins, published on 23 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59048 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao-plugins (Go): affected all versions; no fix listed
- github.com/openbao/openbao-plugins (Go): affected all versions; fixed in 0.1.1
- github.com/openbao/openbao-plugins (Go): affected all versions; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59048/ (Markdown: https://insights.sbomify.com/CVE-2025-59048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59048
- OSV: https://osv.dev/vulnerability/CVE-2025-59048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59048/
Summaries are generated and may contain mistakes; the official description above is the record.
