# CVE-2025-59057: React Router has XSS Vulnerability

> Attackers can execute arbitrary JavaScript via SSR in React Router's meta APIs when using Framework Mode with untrusted content.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLSA-2026-1775521864, CLSA-2026-1792161540, CLSA-2026-1792279964, GHSA-3cgp-3xvw-98x8

## What is CVE-2025-59057?

CVE-2025-59057 is a high-severity cross-site scripting vulnerability in remix-run react-router, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59057?

4 open source packages ship an affected version, including @remix-run/react and react-router. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@remix-run/react` | npm | From 1.15.0 | 2.17.1 |
| `@remix-run/react` | npm | From 1.15.0 | 2.17.1 |
| `react-router` | npm | From 7.0.0 | 7.9.0 |
| `react-router` | npm | From 7.0.0 | 7.9.0 |

Products: Shopify React-Router, Shopify Remix-Run\/React.

## How do I fix CVE-2025-59057?

Upgrade @remix-run/react to 2.17.1 or later.

## Is CVE-2025-59057 being exploited?

There is no known exploitation of CVE-2025-59057 in the wild and no public exploit code.

Public exploit code:

- A XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. (github_poc): https://github.com/boroeurnprach/CVE-2025-59057-PoC

## Other vulnerabilities in remix-run react-router

- [CVE-2026-55685](https://insights.sbomify.com/CVE-2026-55685/): React Router: Unauthenticated Denial of Service via Inefficient Route Matching (high 8.7)
- [CVE-2026-21884](https://insights.sbomify.com/CVE-2026-21884/): React Router SSR XSS in ScrollRestoration (high 8.2)
- [CVE-2026-42211](https://insights.sbomify.com/CVE-2026-42211/): React Router's vendored turbo-stream v2 allows arbitrary constructor invocation via TYPE_ERROR deserialization leading to Unauth RCE (high 8.1)
- [CVE-2026-33245](https://insights.sbomify.com/CVE-2026-33245/): React Router vulnerable to XSS in unstable RSC redirect handling via javascript: redirect targets (high 8.0)
- [CVE-2026-22029](https://insights.sbomify.com/CVE-2026-22029/): React Router vulnerable to XSS via Open Redirects (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59057 and fix it if it is affected.

What it is: CVE-2025-59057 is a high-severity cross-site scripting vulnerability in remix-run react-router, published on 10 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59057 in the wild and no public exploit code.

Affected packages and fixed versions:
- @remix-run/react (npm): affected from 1.15.0; fixed in 2.17.1
- @remix-run/react (npm): affected from 1.15.0; fixed in 2.17.1
- react-router (npm): affected from 7.0.0; fixed in 7.9.0
- react-router (npm): affected from 7.0.0; fixed in 7.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59057/ (Markdown: https://insights.sbomify.com/CVE-2025-59057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59057
- OSV: https://osv.dev/vulnerability/CVE-2025-59057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59057/
Summaries are generated and may contain mistakes; the official description above is the record.
