# CVE-2025-59058: httpsig-rs's HMAC verification is vulnerable to timing attack

> Attackers can forge HTTP message signatures via timing attacks on HMAC verification, bypassing authentication in applications using this Rust library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2025
- **Updated:** 12 Sep 2025
- **Also known as:** GHSA-q7pg-9pr4-mrp2

## What is CVE-2025-59058?

CVE-2025-59058 is a medium-severity vulnerability in junkurihara httpsig-rs, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

httpsig-rs is a Rust implementation of IETF RFC 9421 http message signatures. Prior to version 0.0.19, the HMAC signature comparison is not timing-safe. This makes anyone who uses HS256 signature verification vulnerable to a timing attack that allows the attacker to forge a signature. Version 0.0.19 fixes the issue.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2025-59058?

2 open source packages ship an affected version, including httpsig.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpsig` | crates.io | All versions | 0.0.19 |
| `httpsig` | crates.io | All versions | 0.0.19 |

## How do I fix CVE-2025-59058?

Upgrade httpsig to 0.0.19 or later.

## Is CVE-2025-59058 being exploited?

There is no known exploitation of CVE-2025-59058 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59058 and fix it if it is affected.

What it is: CVE-2025-59058 is a medium-severity vulnerability in junkurihara httpsig-rs, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59058 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpsig (crates.io): affected all versions; fixed in 0.0.19
- httpsig (crates.io): affected all versions; fixed in 0.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59058/ (Markdown: https://insights.sbomify.com/CVE-2025-59058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59058
- OSV: https://osv.dev/vulnerability/CVE-2025-59058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59058/
Summaries are generated and may contain mistakes; the official description above is the record.
