CVE-2025-59059 Apache Ranger: Remote Code Execution Vulnerability in NashornScriptEngineCreator

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-59059?

CVE-2025-59059 is a critical vulnerability in Apache Ranger, published on 3 Mar 2026.

Official description

Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.

Weakness: CWE-94

Which versions are affected by CVE-2025-59059?

2 open source packages ship an affected version, including org.apache.ranger:ranger-plugins-common. It affects 1 product.

PackageAffectedFixed in
org.apache.ranger:ranger-plugins-common MavenAll versions2.8.0
org.apache.ranger:ranger-plugins-common MavenAll versions2.8.0

Products include Apache Ranger.

How do I fix CVE-2025-59059?

Upgrade org.apache.ranger:ranger-plugins-common to 2.8.0 or later.

Is CVE-2025-59059 being exploited?

There is no known exploitation of CVE-2025-59059 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as ECHO-f414-1e9c-fa8f, GHSA-c87w-642h-m97h.

Is CVE-2025-59059 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free