CVE-2025-59060 Apache Ranger: Hostname verification bypass in NiFiRegistryClient

Medium 5.3 Published Updated

Attackers can bypass hostname verification in Apache Ranger's NiFiRegistryClient, potentially enabling man-in-the-middle attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59060?

CVE-2025-59060 is a medium-severity vulnerability in Apache Ranger, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Hostname verification bypass issue in Apache Ranger NiFiRegistryClient is reported in Apache Ranger versions <= 2.7.0.

Users are recommended to upgrade to version 2.8.0, which fixes this issue.

Weakness: CWE-297

Which versions are affected by CVE-2025-59060?

2 open source packages ship an affected version, including org.apache.ranger:ranger-nifi-registry-plugin. It affects 1 product.

PackageAffectedFixed in
org.apache.ranger:ranger-nifi-registry-plugin MavenAll versions2.8.0
org.apache.ranger:ranger-nifi-registry-plugin MavenAll versions2.8.0

Products include Apache Ranger.

How do I fix CVE-2025-59060?

Upgrade org.apache.ranger:ranger-nifi-registry-plugin to 2.8.0 or later.

Is CVE-2025-59060 being exploited?

There is no known exploitation of CVE-2025-59060 in the wild and no public exploit code.

Sources

Also known as GHSA-5fvg-qwcp-r325.

Is CVE-2025-59060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free