CVE-2025-59118 Apache OFBiz: Critical Remote Command Execution via Unrestricted File Upload
Attackers can achieve remote code execution by uploading malicious files to Apache OFBiz, requiring an upgrade to the latest version.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-59118?
CVE-2025-59118 is a high-severity vulnerability in Apache Ofbiz, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Unrestricted Upload of File with Dangerous Type vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: before 24.09.03.
Users are recommended to upgrade to version 24.09.03, which fixes the issue.
Weakness: CWE-434
Which versions are affected by CVE-2025-59118?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2025-59118?
No fix has been published for CVE-2025-59118 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-59118 being exploited?
There is no known exploitation of CVE-2025-59118 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-7fmc-f7mg-gr67.