# CVE-2025-59139: Hono has Body Limit Middleware Bypass

> Attackers can bypass body size limits in Hono framework by sending conflicting HTTP headers, potentially causing denial of service through resource exhaustion.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2025
- **Updated:** 12 Sep 2025
- **Also known as:** GHSA-92vj-g62v-jqhh, MINI-qr2c-cccf-6gw7

## What is CVE-2025-59139?

CVE-2025-59139 is a medium-severity denial of service vulnerability in honojs hono, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono is a Web application framework that provides support for any JavaScript runtime. In versions prior to 4.9.7, a flaw in the `bodyLimit` middleware could allow bypassing the configured request body size limit when conflicting HTTP headers were present. The middleware previously prioritized the `Content-Length` header even when a `Transfer-Encoding: chunked` header was also included. According to the HTTP specification, `Content-Length` must be ignored in such cases. This discrepancy could allow oversized request bodies to bypass the configured limit. Most standards-compliant runtimes and reverse proxies may reject such malformed requests with `400 Bad Request`, so the practical impact depends on the runtime and deployment environment. If body size limits are used as a safeguard against large or malicious requests, this flaw could allow attackers to send oversized request bodies. The primary risk is denial of service (DoS) due to excessive memory or CPU consumption when handling very large requests. The implementation has been updated to align with the HTTP specification, ensuring that `Transfer-Encoding` takes precedence over `Content-Length`. The issue is fixed in Hono v4.9.7, and all users should upgrade immediately.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-59139?

2 open source packages ship an affected version, including hono. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.9.7 |
| `hono` | npm | All versions | 4.9.7 |

Products: Hono Hono.

## How do I fix CVE-2025-59139?

Upgrade hono to 4.9.7 or later.

## Is CVE-2025-59139 being exploited?

There is no known exploitation of CVE-2025-59139 in the wild and no public exploit code.

Public exploit code:

- Cursor plugin for Hono v4 (TypeScript edge web framework). 59 LLM regressions with BAD/CORRECT pairs. Pinned to hono ^4.12.19 (>= 4.9.7 for CVE-2025-59139). Covers Express middleware leakage, v3-era removed APIs, RPC inference traps, Cloudflare Workers gotchas, security defaults, JSX SSR hardening. (github_poc): https://github.com/RoninForge/roninforge-hono

## Other vulnerabilities in honojs hono

- [CVE-2026-27700](https://insights.sbomify.com/CVE-2026-27700/): Hono is Vulnerable to Authentication Bypass by IP Spoofing in AWS Lambda ALB conninfo (high 8.2)
- [CVE-2026-22817](https://insights.sbomify.com/CVE-2026-22817/): JWT Algorithm Confusion via Unsafe Default (HS256) in Hono JWT Middleware Allows Token Forgery and Auth Bypass (high 8.2)
- [CVE-2026-22818](https://insights.sbomify.com/CVE-2026-22818/): JWT algorithm confusion in Hono JWK Auth Middleware when JWK lacks "alg" (untrusted header.alg fallback) (high 8.2)
- [CVE-2025-62610](https://insights.sbomify.com/CVE-2025-62610/): Hono Improperly Authorizes JWT Audience Validation (high 8.1)
- [CVE-2026-29045](https://insights.sbomify.com/CVE-2026-29045/): Hono: Arbitrary file access via serveStatic vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59139 and fix it if it is affected.

What it is: CVE-2025-59139 is a medium-severity denial of service vulnerability in honojs hono, published on 12 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59139 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.9.7
- hono (npm): affected all versions; fixed in 4.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59139/ (Markdown: https://insights.sbomify.com/CVE-2025-59139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59139
- OSV: https://osv.dev/vulnerability/CVE-2025-59139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59139/
Summaries are generated and may contain mistakes; the official description above is the record.
