{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-59146 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-59146 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59146 is a high-severity server-side request forgery vulnerability in QuantumNous new-api, published on 9 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59146 and fix it if it is affected.\n\nWhat it is: CVE-2025-59146 is a high-severity server-side request forgery vulnerability in QuantumNous new-api, published on 9 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59146 in the wild and no public exploit code.\n\nAffected product: QuantumNous new-api. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59146/ (Markdown: https://insights.sbomify.com/CVE-2025-59146/index.md)","id":"CVE-2025-59146","markdown":"https://insights.sbomify.com/CVE-2025-59146/index.md","name":"CVE-2025-59146","record":{"aliases":["GHSA-xxv6-m6fx-vfhh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM gateway","requires_auth":"low_privilege","summary":"Authenticated users can exploit an SSRF vulnerability in New API to coerce the server into making requests to arbitrary internal or external services.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. An authenticated Server-Side Request Forgery (SSRF) vulnerability exists in versions prior to 0.9.0.5. A feature within the application allows authenticated users to submit a URL for the server to process its content. The application fails to properly validate this user-supplied URL before making a server-side request. This vulnerability is not limited to image URLs and can be triggered with any link provided to the vulnerable endpoint. Since user registration is often enabled by default, any registered user can exploit this. By crafting a malicious URL, an attacker can coerce the server to send requests to arbitrary internal or external services. The vulnerability has been patched in version 0.9.0.5. The patch introduces a comprehensive, user-configurable SSRF protection module, which is enabled by default to protect server security. This new feature provides administrators with granular control over outbound requests made by the server. For users who cannot upgrade immediately, some temporary mitigation options are available. Enable new-api image processing worker (new-api-worker) and/or configure egress firewall rules.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"New API has Authenticated Server-Side Request Forgery (SSRF) issue","id":"CVE-2025-59146","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Suricata is Vulnerable to Detection Bypass via Crafted Multiple SYN Packets","id":"CVE-2025-59147"},"packages":[],"prev":{"headline":"color-name@2.0.1 contains malware after npm account takeover","id":"CVE-2025-59145"},"products":["new-api"],"published":"2025-10-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-09","vendors":["QuantumNous"]},"summary":"Authenticated users can exploit an SSRF vulnerability in New API to coerce the server into making requests to arbitrary internal or external services.","url":"https://insights.sbomify.com/CVE-2025-59146/"}