# CVE-2025-59146: New API has Authenticated Server-Side Request Forgery (SSRF) issue

> Authenticated users can exploit an SSRF vulnerability in New API to coerce the server into making requests to arbitrary internal or external services.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Oct 2025
- **Updated:** 9 Oct 2025
- **Also known as:** GHSA-xxv6-m6fx-vfhh

## What is CVE-2025-59146?

CVE-2025-59146 is a high-severity server-side request forgery vulnerability in QuantumNous new-api, published on 9 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. An authenticated Server-Side Request Forgery (SSRF) vulnerability exists in versions prior to 0.9.0.5. A feature within the application allows authenticated users to submit a URL for the server to process its content. The application fails to properly validate this user-supplied URL before making a server-side request. This vulnerability is not limited to image URLs and can be triggered with any link provided to the vulnerable endpoint. Since user registration is often enabled by default, any registered user can exploit this. By crafting a malicious URL, an attacker can coerce the server to send requests to arbitrary internal or external services. The vulnerability has been patched in version 0.9.0.5. The patch introduces a comprehensive, user-configurable SSRF protection module, which is enabled by default to protect server security. This new feature provides administrators with granular control over outbound requests made by the server. For users who cannot upgrade immediately, some temporary mitigation options are available. Enable new-api image processing worker (new-api-worker) and/or configure egress firewall rules.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-59146?


## How do I fix CVE-2025-59146?

No fix has been published for CVE-2025-59146 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59146 being exploited?

There is no known exploitation of CVE-2025-59146 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59146 and fix it if it is affected.

What it is: CVE-2025-59146 is a high-severity server-side request forgery vulnerability in QuantumNous new-api, published on 9 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59146 in the wild and no public exploit code.

Affected product: QuantumNous new-api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59146/ (Markdown: https://insights.sbomify.com/CVE-2025-59146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59146
- OSV: https://osv.dev/vulnerability/CVE-2025-59146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59146/
Summaries are generated and may contain mistakes; the official description above is the record.
