# CVE-2025-59151: Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection

> Attackers can inject CRLF characters to manipulate HTTP headers, enabling session fixation and bypassing browser security controls in Pi-hole Admin Interface.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Oct 2025
- **Updated:** 27 Oct 2025
- **Also known as:** GHSA-5v79-p56f-x7c4

## What is CVE-2025-59151?

CVE-2025-59151 is a high-severity vulnerability in pi-hole web, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level advertisement and internet tracker blocking application. Pi-hole Admin Interface before 6.3 is vulnerable to Carriage Return Line Feed (CRLF) injection. When a request is made to a file ending with the .lp extension, the application performs a redirect without properly sanitizing the input. An attacker can inject carriage return and line feed characters (%0d%0a) to manipulate both the headers and the content of the HTTP response. This enables the injection of arbitrary HTTP response headers, potentially leading to session fixation, cache poisoning, and the weakening or bypassing of browser-based security mechanisms such as Content Security Policy or X-XSS-Protection. This vulnerability is fixed in 6.3.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2025-59151?

It affects 1 product.


Products: Pi-Hole Web Interface.

## How do I fix CVE-2025-59151?

No fix has been published for CVE-2025-59151 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59151 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59151 exists.

## Other vulnerabilities in pi-hole web

- [CVE-2026-33765](https://insights.sbomify.com/CVE-2026-33765/): Pi-hole Web Interface has a Command Injection Vulnerability (high 8.9)
- [CVE-2023-23614](https://insights.sbomify.com/CVE-2023-23614/): Improper session handling of "Remember me for 7 days" functionality (high 8.8)
- [CVE-2021-3706](https://insights.sbomify.com/CVE-2021-3706/): Sensitive Cookie Without 'HttpOnly' Flag in pi-hole/adminlte (high 7.4)
- [CVE-2021-41175](https://insights.sbomify.com/CVE-2021-41175/): Stored XSS in Client Groups Management (Authenticated) (high 7.3)
- [CVE-2021-3811](https://insights.sbomify.com/CVE-2021-3811/): Cross-site Scripting (XSS) - Reflected in pi-hole/adminlte (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59151 and fix it if it is affected.

What it is: CVE-2025-59151 is a high-severity vulnerability in pi-hole web, published on 27 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59151 exists.

Affected product: pi-hole web. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59151/ (Markdown: https://insights.sbomify.com/CVE-2025-59151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59151
- OSV: https://osv.dev/vulnerability/CVE-2025-59151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59151/
Summaries are generated and may contain mistakes; the official description above is the record.
