{"answers":{"affected":"2 open source packages ship an affected version, including org.igniterealtime.openfire:xmppserver.","exploited":"There is no known exploitation of CVE-2025-59154 in the wild and no public exploit code.","fix":"Upgrade org.igniterealtime.openfire:xmppserver to 5.0.2 or later.","what":"CVE-2025-59154 is a medium-severity authentication bypass vulnerability in igniterealtime Openfire, published on 15 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59154 and fix it if it is affected.\n\nWhat it is: CVE-2025-59154 is a medium-severity authentication bypass vulnerability in igniterealtime Openfire, published on 15 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59154 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.igniterealtime.openfire:xmppserver (Maven): affected all versions; fixed in 5.0.2\n- org.igniterealtime.openfire:xmppserver (Maven): affected all versions; fixed in 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59154/ (Markdown: https://insights.sbomify.com/CVE-2025-59154/index.md)","id":"CVE-2025-59154","markdown":"https://insights.sbomify.com/CVE-2025-59154/index.md","name":"CVE-2025-59154","record":{"aliases":["GHSA-w252-645g-87mp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"XMPP server","requires_auth":"high_privilege","summary":"Attackers can impersonate users by crafting certificates with spoofed Common Names if SASL EXTERNAL is enabled, requiring an upgrade to Openfire.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"Openfire is an XMPP server licensed under the Open Source Apache License. Openfire’s SASL EXTERNAL mechanism for client TLS authentication contains a vulnerability in how it extracts user identities from X.509 certificates. Instead of parsing the structured ASN.1 data, the code calls X509Certificate.getSubjectDN().getName() and applies a regex to look for CN=. This method produces a provider-dependent string that does not escape special characters. In SunJSSE (sun.security.x509.X500Name), for example, commas and equals signs inside attribute values are not escaped. As a result, a malicious certificate can embed CN= inside another attribute value (e.g. OU=\"CN=admin,\"). The regex will incorrectly interpret this as a legitimate Common Name and extract admin. If SASL EXTERNAL is enabled and configured to map CNs to user accounts, this allows the attacker to impersonate another user. The fix is included in Openfire 5.0.2 and 5.1.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Openfire allows potential identity spoofing via unsafe CN parsing","id":"CVE-2025-59154","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"hackmd-mcp server-side request forgery in HTTP transport mode","id":"CVE-2025-59155"},"packages":[{"ecosystem":"Maven","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"org.igniterealtime.openfire:xmppserver","purl":null,"source":"GHSA-w252-645g-87mp"},{"ecosystem":"Maven","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"org.igniterealtime.openfire:xmppserver","purl":"pkg:maven/org.igniterealtime.openfire/xmppserver","source":"GHSA-w252-645g-87mp"}],"prev":{"headline":"X-Forwarded-For Header Spoofing Bypasses Litestar Rate Limiting","id":"CVE-2025-59152"},"products":["Openfire"],"published":"2025-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-15","vendors":["igniterealtime"]},"summary":"Attackers can impersonate users by crafting certificates with spoofed Common Names if SASL EXTERNAL is enabled, requiring an upgrade to Openfire.","url":"https://insights.sbomify.com/CVE-2025-59154/"}