{"answers":{"affected":"2 open source packages ship an affected version, including hackmd-mcp.","exploited":"There is no known exploitation of CVE-2025-59155 in the wild and no public exploit code.","fix":"Upgrade hackmd-mcp to 1.5.0 or later.","what":"CVE-2025-59155 is a medium-severity server-side request forgery vulnerability in yuna0x0 hackmd-mcp, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59155 and fix it if it is affected.\n\nWhat it is: CVE-2025-59155 is a medium-severity server-side request forgery vulnerability in yuna0x0 hackmd-mcp, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59155 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hackmd-mcp (npm): affected from 1.4.0; fixed in 1.5.0\n- hackmd-mcp (npm): affected from 1.4.0; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59155/ (Markdown: https://insights.sbomify.com/CVE-2025-59155/index.md)","id":"CVE-2025-59155","markdown":"https://insights.sbomify.com/CVE-2025-59155/index.md","name":"CVE-2025-59155","record":{"aliases":["GHSA-g5cg-6c7v-mmpw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"MCP server library","requires_auth":"none","summary":"Attackers can exploit SSRF in HTTP transport mode to access internal network services and bypass access controls in hackmd-mcp.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"hackmd-mcp is a Model Context Protocol server for integrating HackMD's note-taking platform with AI assistants. From 1.4.0 to before 1.5.0, hackmd-mcp contains a server-side request forgery (SSRF) vulnerability when the server is run in HTTP transport mode. Arbitrary hackmdApiUrl values supplied via the Hackmd-Api-Url HTTP header or a base64-encoded JSON query parameter are accepted without validation, allowing attackers to redirect outbound API requests to internal network services, access internal endpoints, perform network reconnaissance, and bypass network access controls. The stdio transport mode is not affected because it only accepts stdio requests. The issue is fixed in version 1.5.0, which enforces allowed endpoints and supports the ALLOWED_HACKMD_API_URLS environment variable. Users should update to 1.5.0 or later or apply documented mitigations such as switching to stdio mode, restricting outbound network access, or filtering the Hackmd-Api-Url header and related query parameter via a reverse proxy.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"hackmd-mcp server-side request forgery in HTTP transport mode","id":"CVE-2025-59155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Coolify has Docker Compose Injection issue","id":"CVE-2025-59156"},"packages":[{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["1.4.0"],"last_affected":[],"package":"hackmd-mcp","purl":null,"source":"GHSA-g5cg-6c7v-mmpw"},{"ecosystem":"npm","fixed":["1.5.0"],"introduced":["1.4.0"],"last_affected":[],"package":"hackmd-mcp","purl":"pkg:npm/hackmd-mcp","source":"GHSA-g5cg-6c7v-mmpw"}],"prev":{"headline":"Openfire allows potential identity spoofing via unsafe CN parsing","id":"CVE-2025-59154"},"products":["hackmd-mcp"],"published":"2025-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-15","vendors":["yuna0x0"]},"summary":"Attackers can exploit SSRF in HTTP transport mode to access internal network services and bypass access controls in hackmd-mcp.","url":"https://insights.sbomify.com/CVE-2025-59155/"}