# CVE-2025-59155: hackmd-mcp server-side request forgery in HTTP transport mode

> Attackers can exploit SSRF in HTTP transport mode to access internal network services and bypass access controls in hackmd-mcp.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-g5cg-6c7v-mmpw

## What is CVE-2025-59155?

CVE-2025-59155 is a medium-severity server-side request forgery vulnerability in yuna0x0 hackmd-mcp, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hackmd-mcp is a Model Context Protocol server for integrating HackMD's note-taking platform with AI assistants. From 1.4.0 to before 1.5.0, hackmd-mcp contains a server-side request forgery (SSRF) vulnerability when the server is run in HTTP transport mode. Arbitrary hackmdApiUrl values supplied via the Hackmd-Api-Url HTTP header or a base64-encoded JSON query parameter are accepted without validation, allowing attackers to redirect outbound API requests to internal network services, access internal endpoints, perform network reconnaissance, and bypass network access controls. The stdio transport mode is not affected because it only accepts stdio requests. The issue is fixed in version 1.5.0, which enforces allowed endpoints and supports the ALLOWED_HACKMD_API_URLS environment variable. Users should update to 1.5.0 or later or apply documented mitigations such as switching to stdio mode, restricting outbound network access, or filtering the Hackmd-Api-Url header and related query parameter via a reverse proxy.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-59155?

2 open source packages ship an affected version, including hackmd-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackmd-mcp` | npm | From 1.4.0 | 1.5.0 |
| `hackmd-mcp` | npm | From 1.4.0 | 1.5.0 |

## How do I fix CVE-2025-59155?

Upgrade hackmd-mcp to 1.5.0 or later.

## Is CVE-2025-59155 being exploited?

There is no known exploitation of CVE-2025-59155 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59155 and fix it if it is affected.

What it is: CVE-2025-59155 is a medium-severity server-side request forgery vulnerability in yuna0x0 hackmd-mcp, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59155 in the wild and no public exploit code.

Affected packages and fixed versions:
- hackmd-mcp (npm): affected from 1.4.0; fixed in 1.5.0
- hackmd-mcp (npm): affected from 1.4.0; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59155/ (Markdown: https://insights.sbomify.com/CVE-2025-59155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59155
- OSV: https://osv.dev/vulnerability/CVE-2025-59155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59155/
Summaries are generated and may contain mistakes; the official description above is the record.
