# CVE-2025-59159: SillyTavern Web Interface Vulnerable to DNS Rebinding

> Attackers can bypass origin checks via DNS rebinding to install malicious extensions or read chats in SillyTavern if host validation is disabled.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-7cxj-w27x-x78q

## What is CVE-2025-59159?

CVE-2025-59159 is a critical vulnerability in SillyTavern, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. In versions prior to 1.13.4, the web user interface for SillyTavern is susceptible to DNS rebinding, allowing attackers to perform actions like install malicious extensions, read chats, inject arbitrary HTML for phishing attacks, etc. The vulnerability has been patched in the version 1.13.4 by introducing a server configuration setting that enables a validation of host names in inbound HTTP requests according to the provided list of allowed hosts: `hostWhitelist.enabled` in config.yaml file or `SILLYTAVERN_HOSTWHITELIST_ENABLED` environment variable. While the setting is disabled by default to honor a wide variety of existing user configurations and maintain backwards compatibility, existing and new users are encouraged to review their server configurations and apply necessary changes to their setup, especially if hosting over the local network while not using SSL.

Weakness: CWE-940 (Improper Verification of Source of a Communication Channel), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2025-59159?

2 open source packages ship an affected version, including sillytavern.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sillytavern` | npm | All versions | 1.13.4 |
| `sillytavern` | npm | All versions | 1.13.4 |

## How do I fix CVE-2025-59159?

Upgrade sillytavern to 1.13.4 or later.

## Is CVE-2025-59159 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59159 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59159 and fix it if it is affected.

What it is: CVE-2025-59159 is a critical vulnerability in SillyTavern, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59159 exists.

Affected packages and fixed versions:
- sillytavern (npm): affected all versions; fixed in 1.13.4
- sillytavern (npm): affected all versions; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59159/ (Markdown: https://insights.sbomify.com/CVE-2025-59159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59159
- OSV: https://osv.dev/vulnerability/CVE-2025-59159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59159/
Summaries are generated and may contain mistakes; the official description above is the record.
