{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2025-5916 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-5916 is a low-severity vulnerability in Libarchive Libarchive, published on 9 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-5916 and fix it if it is affected.\n\nWhat it is: CVE-2025-5916 is a low-severity vulnerability in Libarchive Libarchive, published on 9 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-5916 in the wild and no public exploit code.\n\nAffected product: Libarchive Libarchive. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5916/ (Markdown: https://insights.sbomify.com/CVE-2025-5916/index.md)","id":"CVE-2025-5916","markdown":"https://insights.sbomify.com/CVE-2025-5916/index.md","name":"CVE-2025-5916","record":{"aliases":["AZL-63759","AZL-63774","AZL-63824","AZL-63863","BELL-CVE-2025-5916","DEBIAN-CVE-2025-5916","ECHO-d190-0a7d-9920","GHSA-fg6q-2hc3-4h9c","JLSEC-2025-248","MINI-h4gj-6jfr-m76x","UBUNTU-CVE-2025-5916","openSUSE-SU-2025:15388-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Libarchive library","requires_auth":"low_privilege","summary":"An integer overflow in Libarchive allows attackers to cause denial of service or memory corruption via malicious WARC files.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"libarchive","vendor":"libarchive"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"openshift_container_platform","vendor":"redhat"}],"cvss":{"score":3.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Libarchive: integer overflow while reading warc files at archive_read_support_format_warc.c","id":"CVE-2025-5916","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"libarchive:libarchive","products":["libarchive:libarchive","redhat:enterprise_linux","redhat:openshift_container_platform"],"type":"integer_overflow","year":"2025"},"n_packages":1,"n_references":4,"next":{"headline":"Libarchive: off by one error in build_ustar_entry_name() at archive_write_set_format_pax.c","id":"CVE-2025-5917"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.9.5-1.1"],"introduced":["0"],"last_affected":[],"package":"rpi-imager","purl":"pkg:rpm/opensuse/rpi-imager\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15388-1"}],"prev":{"headline":"Libarchive: heap buffer over read in copy_from_lzss_window() at archive_read_support_format_rar.c","id":"CVE-2025-5915"},"products":["Red Hat Enterprise Linux 10","Red Hat Enterprise Linux 6","Red Hat Enterprise Linux 7","Red Hat Enterprise Linux 8","Red Hat Enterprise Linux 9","Red Hat OpenShift Container Platform 4"],"published":"2025-06-09","related":[{"cvss_score":9.1,"headline":"Memory corruption in n/a","id":"CVE-2024-37407","kev_date_added":null,"published":"2024-06-08"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2016-1541","kev_date_added":null,"published":"2016-05-07"},{"cvss_score":8.6,"headline":"Integer overflow in n/a","id":"CVE-2016-6250","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":7.8,"headline":"Libarchive: double free at archive_read_format_rar_seek_data() in archive_read_support_format_rar.c","id":"CVE-2025-5914","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2024-48957","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2024-48958","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":7.8,"headline":"Integer overflow in n/a","id":"CVE-2016-4300","kev_date_added":null,"published":"2016-09-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-01","vendors":["Red Hat"]},"summary":"An integer overflow in Libarchive allows attackers to cause denial of service or memory corruption via malicious WARC files.","url":"https://insights.sbomify.com/CVE-2025-5916/"}