# CVE-2025-59160: matrix-js-sdk has insufficient validation when considering a room to be upgraded by another

> Attackers can replace tombstoned rooms with unrelated rooms due to insufficient validation, potentially misleading clients about room history.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** DEBIAN-CVE-2025-59160, GHSA-mp7c-m3rh-r56v, UBUNTU-CVE-2025-59160

## What is CVE-2025-59160?

CVE-2025-59160 is a low-severity vulnerability in matrix-org matrix-js-sdk, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Matrix JavaScript SDK is a Matrix Client-Server SDK for JavaScript and TypeScript. matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room. The issue has been patched and users should upgrade to 38.2.0. A workaround is to avoid using MatrixClient::getJoinedRooms in favor of getRooms() and filtering upgraded rooms separately.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2025-59160?

2 open source packages ship an affected version, including matrix-js-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-js-sdk` | npm | All versions | 38.2.0 |
| `matrix-js-sdk` | npm | All versions | 38.2.0 |

## How do I fix CVE-2025-59160?

Upgrade matrix-js-sdk to 38.2.0 or later.

## Is CVE-2025-59160 being exploited?

There is no known exploitation of CVE-2025-59160 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59160 and fix it if it is affected.

What it is: CVE-2025-59160 is a low-severity vulnerability in matrix-org matrix-js-sdk, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59160 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-js-sdk (npm): affected all versions; fixed in 38.2.0
- matrix-js-sdk (npm): affected all versions; fixed in 38.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59160/ (Markdown: https://insights.sbomify.com/CVE-2025-59160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59160
- OSV: https://osv.dev/vulnerability/CVE-2025-59160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59160/
Summaries are generated and may contain mistakes; the official description above is the record.
