# CVE-2025-59161: Business logic in element-web

> A malicious Matrix room can temporarily hide or replace another room in the client list, potentially confusing users into acting on incorrect information.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** GHSA-m6c8-98f4-75rr, openSUSE-SU-2025:15558-1, openSUSE-SU-2025:15559-1

## What is CVE-2025-59161?

CVE-2025-59161 is a low-severity vulnerability in element-hq element-web, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Element Web is a Matrix web client built using the Matrix React SDK. Element Web and Element Desktop before version 1.11.112 have insufficient validation of room predecessor links, allowing a remote attacker to attempt to impermanently replace a room's entry in the room list with an unrelated attacker-supplied room. While the effect of this is temporary, it may still confuse users into acting on incorrect assumptions. The issue has been patched and users should upgrade to 1.11.112. A reload/refresh will fix the incorrect room list state, removing the attacker's room and restoring the original room.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-59161?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `element-desktop` | openSUSE:Tumbleweed | All versions | 1.11.112-1.1 |
| `element-web` | openSUSE:Tumbleweed | All versions | 1.11.112-1.1 |

## How do I fix CVE-2025-59161?

Upgrade to a fixed version.

## Is CVE-2025-59161 being exploited?

There is no known exploitation of CVE-2025-59161 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59161 and fix it if it is affected.

What it is: CVE-2025-59161 is a low-severity vulnerability in element-hq element-web, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59161 in the wild and no public exploit code.

Affected product: element-hq element-web. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59161/ (Markdown: https://insights.sbomify.com/CVE-2025-59161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59161
- OSV: https://osv.dev/vulnerability/CVE-2025-59161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59161/
Summaries are generated and may contain mistakes; the official description above is the record.
