{"answers":{"affected":"3 open source packages ship an affected version, including github.com/safedep/vet.","exploited":"There is no known exploitation of CVE-2025-59163 in the wild and no public exploit code.","fix":"Upgrade github.com/safedep/vet to 1.12.5 or later.","what":"CVE-2025-59163 is a low-severity server-side request forgery vulnerability in safedep vet, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59163 and fix it if it is affected.\n\nWhat it is: CVE-2025-59163 is a low-severity server-side request forgery vulnerability in safedep vet, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59163 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/safedep/vet (Go): affected all versions; fixed in 1.12.5\n- github.com/safedep/vet (Go): affected all versions; fixed in 1.12.5\n- github.com/safedep/vet (Go): affected all versions; fixed in 1.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59163/ (Markdown: https://insights.sbomify.com/CVE-2025-59163/index.md)","id":"CVE-2025-59163","markdown":"https://insights.sbomify.com/CVE-2025-59163/index.md","name":"CVE-2025-59163","record":{"aliases":["GHSA-6q9c-m9fr-865m","GO-2025-3986"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Supply chain security tool","requires_auth":"none","summary":"Remote attackers can expose vet scan database data via DNS rebinding when using the SSE transport mode.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-350","name":"Reliance on Reverse DNS Resolution for a Security-Critical Action"}],"description":"vet is an open source software supply chain security tool. Versions 1.12.4 and below are vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. Data from the vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool. This issue is fixed in version 1.12.5.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vet MCP Server SSE Transport DNS Rebinding Vulnerability","id":"CVE-2025-59163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"Advantech DeviceOn/iEdge Path Traversal","id":"CVE-2025-59171"},"packages":[{"ecosystem":"Go","fixed":["1.12.5"],"introduced":["0"],"last_affected":[],"package":"github.com/safedep/vet","purl":null,"source":"GHSA-6q9c-m9fr-865m"},{"ecosystem":"Go","fixed":["1.12.5"],"introduced":["0"],"last_affected":[],"package":"github.com/safedep/vet","purl":"pkg:golang/github.com/safedep/vet","source":"GHSA-6q9c-m9fr-865m"},{"ecosystem":"Go","fixed":["1.12.5"],"introduced":["0"],"last_affected":[],"package":"github.com/safedep/vet","purl":"pkg:golang/github.com/safedep/vet","source":"GO-2025-3986"}],"prev":{"headline":"color-convert@3.1.1 contains malware after npm account takeover","id":"CVE-2025-59162"},"products":["vet"],"published":"2025-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-30","vendors":["safedep"]},"summary":"Remote attackers can expose vet scan database data via DNS rebinding when using the SSE transport mode.","url":"https://insights.sbomify.com/CVE-2025-59163/"}