# CVE-2025-59163: vet MCP Server SSE Transport DNS Rebinding Vulnerability

> Remote attackers can expose vet scan database data via DNS rebinding when using the SSE transport mode.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Sep 2025
- **Updated:** 30 Sep 2025
- **Also known as:** GHSA-6q9c-m9fr-865m, GO-2025-3986

## What is CVE-2025-59163?

CVE-2025-59163 is a low-severity server-side request forgery vulnerability in safedep vet, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vet is an open source software supply chain security tool. Versions 1.12.4 and below are vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. Data from the vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool. This issue is fixed in version 1.12.5.

Weakness: CWE-350 (Reliance on Reverse DNS Resolution for a Security-Critical Action)

## Which versions are affected by CVE-2025-59163?

3 open source packages ship an affected version, including github.com/safedep/vet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/safedep/vet` | Go | All versions | 1.12.5 |
| `github.com/safedep/vet` | Go | All versions | 1.12.5 |
| `github.com/safedep/vet` | Go | All versions | 1.12.5 |

## How do I fix CVE-2025-59163?

Upgrade github.com/safedep/vet to 1.12.5 or later.

## Is CVE-2025-59163 being exploited?

There is no known exploitation of CVE-2025-59163 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59163 and fix it if it is affected.

What it is: CVE-2025-59163 is a low-severity server-side request forgery vulnerability in safedep vet, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59163 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/safedep/vet (Go): affected all versions; fixed in 1.12.5
- github.com/safedep/vet (Go): affected all versions; fixed in 1.12.5
- github.com/safedep/vet (Go): affected all versions; fixed in 1.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59163/ (Markdown: https://insights.sbomify.com/CVE-2025-59163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59163
- OSV: https://osv.dev/vulnerability/CVE-2025-59163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59163/
Summaries are generated and may contain mistakes; the official description above is the record.
