# CVE-2025-59288: Playwright Spoofing Vulnerability

> An attacker can spoof content by bypassing cryptographic signature verification in the Playwright library over an adjacent network.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2025
- **Updated:** 22 Feb 2026
- **Also known as:** GHSA-7mvr-c777-76hp, ROOT-APP-NPM-CVE-2025-59288

## What is CVE-2025-59288?

CVE-2025-59288 is a medium-severity vulnerability in microsoft/playwright, published on 14 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper verification of cryptographic signature in Github: Playwright allows an unauthorized attacker to perform spoofing over an adjacent network.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-59288?

2 open source packages ship an affected version, including playwright. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `playwright` | npm | All versions | 1.55.1 |
| `playwright` | npm | All versions | 1.55.1 |

Products: Microsoft Playwright.

## How do I fix CVE-2025-59288?

Upgrade playwright to 1.55.1 or later.

## Is CVE-2025-59288 being exploited?

There is no known exploitation of CVE-2025-59288 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59288 and fix it if it is affected.

What it is: CVE-2025-59288 is a medium-severity vulnerability in microsoft/playwright, published on 14 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59288 in the wild and no public exploit code.

Affected packages and fixed versions:
- playwright (npm): affected all versions; fixed in 1.55.1
- playwright (npm): affected all versions; fixed in 1.55.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59288/ (Markdown: https://insights.sbomify.com/CVE-2025-59288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59288
- OSV: https://osv.dev/vulnerability/CVE-2025-59288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59288/
Summaries are generated and may contain mistakes; the official description above is the record.
