{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59302 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-59302 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59302 is a medium-severity code injection vulnerability in Apache Cloudstack, published on 27 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59302 and fix it if it is affected.\n\nWhat it is: CVE-2025-59302 is a medium-severity code injection vulnerability in Apache Cloudstack, published on 27 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59302 in the wild and no public exploit code.\n\nAffected product: Apache Cloudstack. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59302/ (Markdown: https://insights.sbomify.com/CVE-2025-59302/index.md)","id":"CVE-2025-59302","markdown":"https://insights.sbomify.com/CVE-2025-59302/index.md","name":"CVE-2025-59302","record":{"aliases":["GHSA-hgmv-qpw9-xrfq"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache CloudStack","requires_auth":"high_privilege","summary":"Admins can execute arbitrary code via JavaScript injection in specific CloudStack APIs, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"cloudstack","vendor":"apache"}],"cvss":{"score":4.7,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"In  Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins.\n\n  *  quotaTariffCreate\n  *  quotaTariffUpdate\n  *  createSecondaryStorageSelector\n  *  updateSecondaryStorageSelector\n  *  updateHost\n  *  updateStorage\n\nThis issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix.\n\nThe fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache CloudStack: Potential remote code execution on Javascript engine defined rules","id":"CVE-2025-59302","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"apache:cloudstack","products":["apache:cloudstack"],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Information disclosure in HAProxy Kubernetes Ingress Controller","id":"CVE-2025-59303"},"packages":[],"prev":{"headline":"Modbus/TCP Dos Vulnerability in DVP15MC11T","id":"CVE-2025-59301"},"products":["Apache CloudStack"],"published":"2025-11-27","related":[{"cvss_score":10,"headline":"Missing authorization in n/a","id":"CVE-2012-4501","kev_date_added":null,"published":"2012-10-26"},{"cvss_score":9.8,"headline":"Apache CloudStack: Unauthenticated cluster service port leads to remote execution","id":"CVE-2024-38346","kev_date_added":null,"published":"2024-07-05"},{"cvss_score":9.8,"headline":"Apache CloudStack: Integration API service uses dynamic port when disabled","id":"CVE-2024-39864","kev_date_added":null,"published":"2024-07-05"},{"cvss_score":9.8,"headline":"Apache CloudStack: x-forwarded-for HTTP header parsed by default","id":"CVE-2024-29006","kev_date_added":null,"published":"2024-04-04"},{"cvss_score":9.8,"headline":"Apache CloudStack SAML Single Sign-On XXE","id":"CVE-2022-35741","kev_date_added":null,"published":"2022-07-18"},{"cvss_score":9.8,"headline":"Command injection in Apache CloudStack","id":"CVE-2019-17562","kev_date_added":null,"published":"2020-05-14"},{"cvss_score":9.8,"headline":"Missing authorization in Apache CloudStack","id":"CVE-2016-6813","kev_date_added":null,"published":"2018-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Apache Software Foundation"]},"summary":"Admins can execute arbitrary code via JavaScript injection in specific CloudStack APIs, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2025-59302/"}