{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.fory:fory-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-59328 in the wild and no public exploit code.","fix":"Upgrade org.apache.fory:fory-core to 0.12.2 or later.","what":"CVE-2025-59328 is a medium-severity unsafe deserialization vulnerability in Apache Fory, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59328 and fix it if it is affected.\n\nWhat it is: CVE-2025-59328 is a medium-severity unsafe deserialization vulnerability in Apache Fory, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59328 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.fory:fory-core (Maven): affected all versions; fixed in 0.12.2\n- org.apache.fory:fory-core (Maven): affected all versions; fixed in 0.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59328/ (Markdown: https://insights.sbomify.com/CVE-2025-59328/index.md)","id":"CVE-2025-59328","markdown":"https://insights.sbomify.com/CVE-2025-59328/index.md","name":"CVE-2025-59328","record":{"aliases":["GHSA-5hmf-8wx5-4qq3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java serialization library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in applications using Apache Fory by sending large malicious payloads that exhaust CPU resources during deserialization.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"fory","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users.\n\nUsers of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Fory: Denial of Service (DoS) due to Deserialization of Untrusted malicious large Data","id":"CVE-2025-59328","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"error-ex@1.3.3 contains malware after npm account takeover","id":"CVE-2025-59330"},"packages":[{"ecosystem":"Maven","fixed":["0.12.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.fory:fory-core","purl":null,"source":"GHSA-5hmf-8wx5-4qq3"},{"ecosystem":"Maven","fixed":["0.12.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.fory:fory-core","purl":"pkg:maven/org.apache.fory/fory-core","source":"GHSA-5hmf-8wx5-4qq3"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2025-59327"},"products":["Apache Fory"],"published":"2025-09-15","related":[{"cvss_score":9.8,"headline":"Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization","id":"CVE-2026-71558","kev_date_added":null,"published":"2026-08-07"},{"cvss_score":9.8,"headline":"Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface","id":"CVE-2026-64606","kev_date_added":null,"published":"2026-07-21"},{"cvss_score":9.8,"headline":"Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths","id":"CVE-2026-64608","kev_date_added":null,"published":"2026-07-21"},{"cvss_score":9.8,"headline":"Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement","id":"CVE-2026-48207","kev_date_added":null,"published":"2026-05-21"},{"cvss_score":9.8,"headline":"Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory","id":"CVE-2025-61622","kev_date_added":null,"published":"2025-10-01"},{"cvss_score":9.1,"headline":"Apache Fory: Out-of-bounds heap read in C++ struct deserializer tagged-int fast-path","id":"CVE-2026-71560","kev_date_added":null,"published":"2026-08-07"},{"cvss_score":9.1,"headline":"Apache Fory, Apache Fory: Out-of-Bounds Read via sun.misc.Unsafe in zero-copy java deserialization","id":"CVE-2026-64609","kev_date_added":null,"published":"2026-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can cause denial of service in applications using Apache Fory by sending large malicious payloads that exhaust CPU resources during deserialization.","url":"https://insights.sbomify.com/CVE-2025-59328/"}