# CVE-2025-59328: Apache Fory: Denial of Service (DoS) due to Deserialization of Untrusted malicious large Data

> Remote attackers can cause denial of service in applications using Apache Fory by sending large malicious payloads that exhaust CPU resources during deserialization.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-5hmf-8wx5-4qq3

## What is CVE-2025-59328?

CVE-2025-59328 is a medium-severity unsafe deserialization vulnerability in Apache Fory, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users.

Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-59328?

2 open source packages ship an affected version, including org.apache.fory:fory-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.fory:fory-core` | Maven | All versions | 0.12.2 |
| `org.apache.fory:fory-core` | Maven | All versions | 0.12.2 |

Products: Apache Fory.

## How do I fix CVE-2025-59328?

Upgrade org.apache.fory:fory-core to 0.12.2 or later.

## Is CVE-2025-59328 being exploited?

There is no known exploitation of CVE-2025-59328 in the wild and no public exploit code.

## Other vulnerabilities in Apache Fory

- [CVE-2026-71558](https://insights.sbomify.com/CVE-2026-71558/): Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization (critical 9.8)
- [CVE-2026-64606](https://insights.sbomify.com/CVE-2026-64606/): Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface (critical 9.8)
- [CVE-2026-64608](https://insights.sbomify.com/CVE-2026-64608/): Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths (critical 9.8)
- [CVE-2026-48207](https://insights.sbomify.com/CVE-2026-48207/): Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement (critical 9.8)
- [CVE-2025-61622](https://insights.sbomify.com/CVE-2025-61622/): Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59328 and fix it if it is affected.

What it is: CVE-2025-59328 is a medium-severity unsafe deserialization vulnerability in Apache Fory, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59328 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.fory:fory-core (Maven): affected all versions; fixed in 0.12.2
- org.apache.fory:fory-core (Maven): affected all versions; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59328/ (Markdown: https://insights.sbomify.com/CVE-2025-59328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59328
- OSV: https://osv.dev/vulnerability/CVE-2025-59328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59328/
Summaries are generated and may contain mistakes; the official description above is the record.
