{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59335 exists.","fix":"No fix has been published for CVE-2025-59335 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59335 is a high-severity vulnerability in cubecart v6, published on 22 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59335 and fix it if it is affected.\n\nWhat it is: CVE-2025-59335 is a high-severity vulnerability in cubecart v6, published on 22 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59335 exists.\n\nAffected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59335/ (Markdown: https://insights.sbomify.com/CVE-2025-59335/index.md)","id":"CVE-2025-59335","markdown":"https://insights.sbomify.com/CVE-2025-59335/index.md","name":"CVE-2025-59335","record":{"aliases":["GHSA-4vwh-x8m2-fmvv"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"CubeCart ecommerce software","requires_auth":"low_privilege","summary":"Attackers retain account access after password changes because sessions are not invalidated, allowing persistent unauthorized access to compromised accounts.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cubecart","vendor":"cubecart"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"CubeCart is an ecommerce software solution. Prior to version 6.5.11, there is an absence of automatic session expiration following a user's password change. This oversight poses a security risk, as if a user forgets to log out from a location where they accessed their account, an unauthorized user can maintain access even after the password has been changed. Due to this bug, if an account has already been compromised, the legitimate user has no way to revoke the attacker’s access. The malicious actor retains full access to the account until their session naturally expires. This means the account remains insecure even after the password has been changed. This issue has been patched in version 6.5.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"CubeCart Session Not Invalidated After Password Change","id":"CVE-2025-59335","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Relative Path Traversal in Luanox","id":"CVE-2025-59336"},"packages":[],"prev":{"headline":"Linkr allows manifest tampering leading to arbitrary file injection","id":"CVE-2025-59334"},"products":["v6"],"published":"2025-09-22","related":[{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2024-34832","kev_date_added":null,"published":"2024-06-06"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2018-20716","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2013-1465","kev_date_added":null,"published":"2013-02-08"},{"cvss_score":8.6,"headline":"Command injection in CubeCart","id":"CVE-2026-21719","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":8.1,"headline":"Cross-site request forgery in CubeCart","id":"CVE-2023-38130","kev_date_added":null,"published":"2023-11-17"},{"cvss_score":8,"headline":"File upload in n/a","id":"CVE-2024-33438","kev_date_added":null,"published":"2024-04-29"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2010-4903","kev_date_added":null,"published":"2011-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-22","vendors":["cubecart"]},"summary":"Attackers retain account access after password changes because sessions are not invalidated, allowing persistent unauthorized access to compromised accounts.","url":"https://insights.sbomify.com/CVE-2025-59335/"}