# CVE-2025-59335: CubeCart Session Not Invalidated After Password Change

> Attackers retain account access after password changes because sessions are not invalidated, allowing persistent unauthorized access to compromised accounts.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-4vwh-x8m2-fmvv

## What is CVE-2025-59335?

CVE-2025-59335 is a high-severity vulnerability in cubecart v6, published on 22 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

CubeCart is an ecommerce software solution. Prior to version 6.5.11, there is an absence of automatic session expiration following a user's password change. This oversight poses a security risk, as if a user forgets to log out from a location where they accessed their account, an unauthorized user can maintain access even after the password has been changed. Due to this bug, if an account has already been compromised, the legitimate user has no way to revoke the attacker’s access. The malicious actor retains full access to the account until their session naturally expires. This means the account remains insecure even after the password has been changed. This issue has been patched in version 6.5.11.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-59335?

It affects 1 product.


Products: Cubecart Cubecart.

## How do I fix CVE-2025-59335?

No fix has been published for CVE-2025-59335 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59335 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59335 exists.

## Other vulnerabilities in cubecart v6

- [CVE-2024-34832](https://insights.sbomify.com/CVE-2024-34832/): Path traversal in n/a (critical 9.8)
- [CVE-2018-20716](https://insights.sbomify.com/CVE-2018-20716/): SQL injection in n/a (critical 9.8)
- [CVE-2013-1465](https://insights.sbomify.com/CVE-2013-1465/): Deserialization in n/a (critical 9.8)
- [CVE-2026-21719](https://insights.sbomify.com/CVE-2026-21719/): Command injection in CubeCart (high 8.6)
- [CVE-2023-38130](https://insights.sbomify.com/CVE-2023-38130/): Cross-site request forgery in CubeCart (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59335 and fix it if it is affected.

What it is: CVE-2025-59335 is a high-severity vulnerability in cubecart v6, published on 22 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59335 exists.

Affected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59335/ (Markdown: https://insights.sbomify.com/CVE-2025-59335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59335
- OSV: https://osv.dev/vulnerability/CVE-2025-59335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59335/
Summaries are generated and may contain mistakes; the official description above is the record.
