{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-59336 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-59336 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59336 is a medium-severity vulnerability in lumen-oss luanox, published on 16 Sep 2025."},"fix_prompt":"Check this codebase for CVE-2025-59336 and fix it if it is affected.\n\nWhat it is: CVE-2025-59336 is a medium-severity vulnerability in lumen-oss luanox, published on 16 Sep 2025. \nExploitation: There is no known exploitation of CVE-2025-59336 in the wild and no public exploit code.\n\nAffected product: lumen-oss luanox. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59336/ (Markdown: https://insights.sbomify.com/CVE-2025-59336/index.md)","id":"CVE-2025-59336","markdown":"https://insights.sbomify.com/CVE-2025-59336/index.md","name":"CVE-2025-59336","record":{"aliases":["GHSA-42c5-x4pj-4p3w"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification system. This causes the uploaded file to be stored at the relative path location. If planned carefully, this could overwrite a runtime file and cause the website to crash. This vulnerability is fixed by 0.1.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Relative Path Traversal in Luanox","id":"CVE-2025-59336","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Discourse: Cross-Site Data Exposure via Backup Restore Metacommand Injection in Multisite Deployments","id":"CVE-2025-59337"},"packages":[],"prev":{"headline":"CubeCart Session Not Invalidated After Password Change","id":"CVE-2025-59335"},"products":["luanox"],"published":"2025-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-16","vendors":["lumen-oss"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-59336/"}