# CVE-2025-59336: Relative Path Traversal in Luanox


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 16 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** GHSA-42c5-x4pj-4p3w

## What is CVE-2025-59336?

CVE-2025-59336 is a medium-severity vulnerability in lumen-oss luanox, published on 16 Sep 2025. 

### Official description

Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification system. This causes the uploaded file to be stored at the relative path location. If planned carefully, this could overwrite a runtime file and cause the website to crash. This vulnerability is fixed by 0.1.1.

Weakness: CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-59336?


## How do I fix CVE-2025-59336?

No fix has been published for CVE-2025-59336 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59336 being exploited?

There is no known exploitation of CVE-2025-59336 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59336 and fix it if it is affected.

What it is: CVE-2025-59336 is a medium-severity vulnerability in lumen-oss luanox, published on 16 Sep 2025. 
Exploitation: There is no known exploitation of CVE-2025-59336 in the wild and no public exploit code.

Affected product: lumen-oss luanox. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59336/ (Markdown: https://insights.sbomify.com/CVE-2025-59336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59336
- OSV: https://osv.dev/vulnerability/CVE-2025-59336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59336/
Summaries are generated and may contain mistakes; the official description above is the record.
