CVE-2025-59337 Discourse: Cross-Site Data Exposure via Backup Restore Metacommand Injection in Multisite Deployments

Medium 5.5 Published Updated

Malicious meta-commands in backup files allow admins to access data from other sites in multisite Discourse deployments.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59337?

CVE-2025-59337 is a medium-severity command injection vulnerability in Discourse Discourse, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.

Weakness: CWE-77

Which versions are affected by CVE-2025-59337?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.1

Products include Discourse Discourse.

How do I fix CVE-2025-59337?

Upgrade discourse to 3.5.1 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-59337 being exploited?

There is no known exploitation of CVE-2025-59337 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-59337, GHSA-7xjr-4f4g-9887.

Is CVE-2025-59337 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free