# CVE-2025-59337: Discourse: Cross-Site Data Exposure via Backup Restore Metacommand Injection in Multisite Deployments

> Malicious meta-commands in backup files allow admins to access data from other sites in multisite Discourse deployments.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 2 Oct 2025
- **Also known as:** BIT-discourse-2025-59337, GHSA-7xjr-4f4g-9887

## What is CVE-2025-59337?

CVE-2025-59337 is a medium-severity command injection vulnerability in Discourse Discourse, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-59337?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.5.1 |

Products: Discourse Discourse.

## How do I fix CVE-2025-59337?

Upgrade discourse to 3.5.1 or later.

## Is CVE-2025-59337 being exploited?

There is no known exploitation of CVE-2025-59337 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59337 and fix it if it is affected.

What it is: CVE-2025-59337 is a medium-severity command injection vulnerability in Discourse Discourse, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59337 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59337/ (Markdown: https://insights.sbomify.com/CVE-2025-59337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59337
- OSV: https://osv.dev/vulnerability/CVE-2025-59337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59337/
Summaries are generated and may contain mistakes; the official description above is the record.
