CVE-2025-5934 Netgear EX3700 mtd sub_41619C stack-based overflow

High 8.7 Published Updated

Remote attackers can exploit a stack-based buffer overflow in the Netgear EX3700 firmware to execute arbitrary code.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-5934?

CVE-2025-5934 is a high-severity memory corruption vulnerability in Netgear EX3700, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Netgear EX3700 up to 1.0.0.88. It has been classified as critical. Affected is the function sub_41619C of the file /mtd. The manipulation leads to stack-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.0.98 is able to address this issue. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-121, CWE-787, CWE-119

Which versions are affected by CVE-2025-5934?

It affects 1 product.

Products include Netgear Ex3700 Firmware.

How do I fix CVE-2025-5934?

No fix has been published for CVE-2025-5934 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-5934 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5934 exists.

Sources

Also known as GHSA-942c-3x7c-8jqx.

Is CVE-2025-5934 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free