# CVE-2025-5934: Netgear EX3700 mtd sub_41619C stack-based overflow

> Remote attackers can exploit a stack-based buffer overflow in the Netgear EX3700 firmware to execute arbitrary code.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-942c-3x7c-8jqx

## What is CVE-2025-5934?

CVE-2025-5934 is a high-severity memory corruption vulnerability in Netgear EX3700, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in Netgear EX3700 up to 1.0.0.88. It has been classified as critical. Affected is the function sub_41619C of the file /mtd. The manipulation leads to stack-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.0.98 is able to address this issue. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-121 (Stack-based Buffer Overflow), CWE-787 (Out-of-bounds Write), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-5934?

It affects 1 product.


Products: Netgear Ex3700 Firmware.

## How do I fix CVE-2025-5934?

No fix has been published for CVE-2025-5934 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5934 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5934 exists.

## Other vulnerabilities in Netgear EX3700

- [CVE-2021-32122](https://insights.sbomify.com/CVE-2021-32122/): Cross-site request forgery in n/a (critical 9.8)
- [CVE-2017-18747](https://insights.sbomify.com/CVE-2017-18747/): Misconfiguration in n/a (high 8.8)
- [CVE-2017-18752](https://insights.sbomify.com/CVE-2017-18752/): Path traversal in n/a (high 8.8)
- [CVE-2017-18772](https://insights.sbomify.com/CVE-2017-18772/): Auth bypass in n/a (high 8.8)
- [CVE-2024-35519](https://insights.sbomify.com/CVE-2024-35519/): Command injection in n/a (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5934 and fix it if it is affected.

What it is: CVE-2025-5934 is a high-severity memory corruption vulnerability in Netgear EX3700, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5934 exists.

Affected product: Netgear EX3700. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5934/ (Markdown: https://insights.sbomify.com/CVE-2025-5934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5934
- OSV: https://osv.dev/vulnerability/CVE-2025-5934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5934/
Summaries are generated and may contain mistakes; the official description above is the record.
