CVE-2025-59355 Apache Linkis: Password Exposure
Attackers with log access can read plaintext passwords from error logs when Base64 decoding fails in Apache Linkis.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-59355?
CVE-2025-59355 is a medium-severity vulnerability in Apache Linkis, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability.
When org.apache.linkis.metadata.util.HiveUtils.decode() fails to perform Base64 decoding, it records the complete input parameter string in the log via logger.error(str + "decode failed", e). If the input parameter contains sensitive information such as Hive Metastore keys, plaintext passwords will be left in the log files when decoding fails, resulting in information leakage.
Affected Scope Component: Sensitive fields in hive-site.xml (e.g., javax.jdo.option.ConnectionPassword) or other fields encoded in Base64. Version: Apache Linkis 1.0.0 – 1.7.0
Trigger Conditions The value of the configuration item is an invalid Base64 string. Log files are readable by users other than hive-site.xml administrators.
Severity: Low The probability of Base64 decoding failure is low. The leakage is only triggered when logs at the Error level are exposed.
Remediation Apache Linkis 1.8.0 and later versions have replaced the log with desensitized content. logger.error("URL decode failed: {}", e.getMessage()); // 不再输出 str
Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Weakness: CWE-532
Which versions are affected by CVE-2025-59355?
2 open source packages ship an affected version, including org.apache.linkis:linkis-metadata. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.linkis:linkis-metadata Maven | From 1.0.0 | 1.8.0 |
org.apache.linkis:linkis-metadata Maven | From 1.0.0 | 1.8.0 |
Products include Apache Linkis.
How do I fix CVE-2025-59355?
Upgrade org.apache.linkis:linkis-metadata to 1.8.0 or later.
Is CVE-2025-59355 being exploited?
There is no known exploitation of CVE-2025-59355 in the wild and no public exploit code.
Other vulnerabilities in Apache Linkis
- CVE-2023-27602 Apache Linkis publicsercice module unrestricted upload of file
- CVE-2023-27603 Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue
- CVE-2023-29215 Apache Linkis JDBC EngineCon has a deserialization command execution
- CVE-2023-29216 Apache Linkis DatasourceManager module has a deserialization command execution
- CVE-2023-27987 Apache Linkis gateway module token authentication bypass
Sources
Also known as GHSA-6vfr-p2hx-6v32.