# CVE-2025-59355: Apache Linkis: Password Exposure

> Attackers with log access can read plaintext passwords from error logs when Base64 decoding fails in Apache Linkis.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-6vfr-p2hx-6v32

## What is CVE-2025-59355?

CVE-2025-59355 is a medium-severity vulnerability in Apache Linkis, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability.

When org.apache.linkis.metadata.util.HiveUtils.decode() fails to perform Base64 decoding, it records the complete input parameter string in the log via logger.error(str + "decode failed", e). If the input parameter contains sensitive information such as Hive Metastore keys, plaintext passwords will be left in the log files when decoding fails, resulting in information leakage.

Affected Scope
Component: Sensitive fields in hive-site.xml (e.g., javax.jdo.option.ConnectionPassword) or other fields encoded in Base64.
Version: Apache Linkis 1.0.0 – 1.7.0

Trigger Conditions
The value of the configuration item is an invalid Base64 string.
Log files are readable by users other than hive-site.xml administrators.

Severity: Low
The probability of Base64 decoding failure is low.
The leakage is only triggered when logs at the Error level are exposed.

Remediation
Apache Linkis 1.8.0 and later versions have replaced the log with desensitized content.
logger.error("URL decode failed: {}", e.getMessage());   // 不再输出 str

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-59355?

2 open source packages ship an affected version, including org.apache.linkis:linkis-metadata. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis-metadata` | Maven | From 1.0.0 | 1.8.0 |
| `org.apache.linkis:linkis-metadata` | Maven | From 1.0.0 | 1.8.0 |

Products: Apache Linkis.

## How do I fix CVE-2025-59355?

Upgrade org.apache.linkis:linkis-metadata to 1.8.0 or later.

## Is CVE-2025-59355 being exploited?

There is no known exploitation of CVE-2025-59355 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59355 and fix it if it is affected.

What it is: CVE-2025-59355 is a medium-severity vulnerability in Apache Linkis, published on 19 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59355 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis-metadata (Maven): affected from 1.0.0; fixed in 1.8.0
- org.apache.linkis:linkis-metadata (Maven): affected from 1.0.0; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59355/ (Markdown: https://insights.sbomify.com/CVE-2025-59355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59355
- OSV: https://osv.dev/vulnerability/CVE-2025-59355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59355/
Summaries are generated and may contain mistakes; the official description above is the record.
