{"answers":{"affected":"2 open source packages ship an affected version, including express-xss-sanitizer.","exploited":"There is no known exploitation of CVE-2025-59364 in the wild and no public exploit code.","fix":"Upgrade express-xss-sanitizer to 2.0.1 or later.","what":"CVE-2025-59364 is a medium-severity denial of service vulnerability in Express XSS Sanitizer, published on 14 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-59364 and fix it if it is affected.\n\nWhat it is: CVE-2025-59364 is a medium-severity denial of service vulnerability in Express XSS Sanitizer, published on 14 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-59364 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-xss-sanitizer (npm): affected all versions; fixed in 2.0.1\n- express-xss-sanitizer (npm): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59364/ (Markdown: https://insights.sbomify.com/CVE-2025-59364/index.md)","id":"CVE-2025-59364","markdown":"https://insights.sbomify.com/CVE-2025-59364/index.md","name":"CVE-2025-59364","record":{"aliases":["GHSA-hvq2-wf92-j4f3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js XSS sanitizer","requires_auth":"none","summary":"An attacker can cause a denial of service via unbounded recursion in the Express XSS Sanitizer library when processing JSON request bodies.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"The express-xss-sanitizer (aka Express XSS Sanitizer) package through 2.0.0 for Node.js has an unbounded recursion depth in sanitize in lib/sanitize.js for a JSON request body.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"express-xss-sanitizer has an unbounded recursion depth","id":"CVE-2025-59364","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in Router","id":"CVE-2025-59365"},"packages":[{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"express-xss-sanitizer","purl":null,"source":"GHSA-hvq2-wf92-j4f3"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"express-xss-sanitizer","purl":"pkg:npm/express-xss-sanitizer","source":"GHSA-hvq2-wf92-j4f3"}],"prev":{"headline":"Information disclosure in OneLogin","id":"CVE-2025-59363"},"products":["Express XSS Sanitizer"],"published":"2025-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-15","vendors":["Express XSS Sanitizer project"]},"summary":"An attacker can cause a denial of service via unbounded recursion in the Express XSS Sanitizer library when processing JSON request bodies.","url":"https://insights.sbomify.com/CVE-2025-59364/"}