CVE-2025-59390 Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly.

Critical 9.8 Published Updated

Apache Druid uses a weak random secret for Kerberos cookies by default, allowing attackers to forge tokens and bypass authentication.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-59390?

CVE-2025-59390 is a critical vulnerability in Apache Druid, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Druid’s Kerberos authenticator uses a weak fallback secret when the `druid.auth.authenticator.kerberos.cookieSignatureSecret` configuration is not explicitly set. In this case, the secret is generated using `ThreadLocalRandom`, which is not a crypto-graphically secure random number generator. This may allow an attacker to predict or brute force the secret used to sign authentication cookies, potentially enabling token forgery or authentication bypass. Additionally, each process generates its own fallback secret, resulting in inconsistent secrets across nodes. This causes authentication failures in distributed or multi-broker deployments, effectively leading to a incorrectly configured clusters. Users are advised to configure a strong `druid.auth.authenticator.kerberos.cookieSignatureSecret`

This issue affects Apache Druid: through 34.0.0.

Users are recommended to upgrade to version 35.0.0, which fixes the issue making it mandatory to set `druid.auth.authenticator.kerberos.cookieSignatureSecret` when using the Kerberos authenticator. Services will fail to come up if the secret is not set.

Weakness: CWE-338

Which versions are affected by CVE-2025-59390?

2 open source packages ship an affected version, including org.apache.druid:druid. It affects 1 product.

PackageAffectedFixed in
org.apache.druid:druid MavenAll versions35.0.0
org.apache.druid:druid MavenAll versions35.0.0

Products include Apache Druid.

How do I fix CVE-2025-59390?

Upgrade org.apache.druid:druid to 35.0.0 or later.

Is CVE-2025-59390 being exploited?

There is no known exploitation of CVE-2025-59390 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-w88f-4875-99c8.

Is CVE-2025-59390 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free