# CVE-2025-59390: Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly.

> Apache Druid uses a weak random secret for Kerberos cookies by default, allowing attackers to forge tokens and bypass authentication.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Nov 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-w88f-4875-99c8

## What is CVE-2025-59390?

CVE-2025-59390 is a critical vulnerability in Apache Druid, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Druid’s Kerberos authenticator uses a weak fallback secret when the `druid.auth.authenticator.kerberos.cookieSignatureSecret` configuration is not explicitly set. In this case, the secret is generated using `ThreadLocalRandom`,
 which is not a crypto-graphically secure random number generator. This 
may allow an attacker to predict or brute force the secret used to sign 
authentication cookies, potentially enabling token forgery or 
authentication bypass. Additionally, each process generates its own 
fallback secret, resulting in inconsistent secrets across nodes. This 
causes authentication failures in distributed or multi-broker 
deployments, effectively leading to a incorrectly configured clusters. Users are 
advised to configure a strong `druid.auth.authenticator.kerberos.cookieSignatureSecret`

This issue affects Apache Druid: through 34.0.0.

Users are recommended to upgrade to version 35.0.0, which fixes the issue making it mandatory to set `druid.auth.authenticator.kerberos.cookieSignatureSecret` when using the Kerberos authenticator. Services will fail to come up if the secret is not set.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2025-59390?

2 open source packages ship an affected version, including org.apache.druid:druid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.druid:druid` | Maven | All versions | 35.0.0 |
| `org.apache.druid:druid` | Maven | All versions | 35.0.0 |

Products: Apache Druid.

## How do I fix CVE-2025-59390?

Upgrade org.apache.druid:druid to 35.0.0 or later.

## Is CVE-2025-59390 being exploited?

There is no known exploitation of CVE-2025-59390 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-59390 and ThreadLocalRandom Inverse (github_poc): https://github.com/Daeda1usUK/CVE-2025-59390-

## Other vulnerabilities in Apache Druid

- [CVE-2026-23906](https://insights.sbomify.com/CVE-2026-23906/): Apache Druid: Authentication Bypass via LDAP Anonymous Bind (critical 9.8)
- [CVE-2021-26919](https://insights.sbomify.com/CVE-2021-26919/): Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. (high 8.8)
- [CVE-2021-25646](https://insights.sbomify.com/CVE-2021-25646/): Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. (high 8.8)
- [CVE-2024-45537](https://insights.sbomify.com/CVE-2024-45537/): Apache Druid: Users can provide MySQL JDBC properties not on allow list (medium 6.5)
- [CVE-2021-36749](https://insights.sbomify.com/CVE-2021-36749/): Druid ingestion system Authenticated users can read data from other sources than intended (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59390 and fix it if it is affected.

What it is: CVE-2025-59390 is a critical vulnerability in Apache Druid, published on 26 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59390 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.druid:druid (Maven): affected all versions; fixed in 35.0.0
- org.apache.druid:druid (Maven): affected all versions; fixed in 35.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59390/ (Markdown: https://insights.sbomify.com/CVE-2025-59390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59390
- OSV: https://osv.dev/vulnerability/CVE-2025-59390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59390/
Summaries are generated and may contain mistakes; the official description above is the record.
