# CVE-2025-59410: Dragonfly tiny file download uses hard coded HTTP protocol

> Attackers can intercept and modify tiny file downloads via Man-in-the-Middle attacks because the scheduler hardcodes HTTP instead of HTTPS.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2025
- **Updated:** 18 Sep 2025
- **Also known as:** GHSA-mcvp-rpgg-9273, GO-2025-3974

## What is CVE-2025-59410?

CVE-2025-59410 is a medium-severity vulnerability in dragonflyoss dragonfly, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dragonfly is an open source P2P-based file distribution and image acceleration system. Prior to 2.1.0, the code in the scheduler for downloading a tiny file is hard coded to use the HTTP protocol, rather than HTTPS. This means that an attacker could perform a Man-in-the-Middle attack, changing the network request so that a different piece of data gets downloaded. This vulnerability is fixed in 2.1.0.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2025-59410?

6 open source packages ship an affected version, including github.com/dragonflyoss/dragonfly and d7y.io/dragonfly/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dragonflyoss/dragonfly` | Go | All versions | None |
| `github.com/dragonflyoss/dragonfly` | Go | All versions | 2.1.0 |
| `github.com/dragonflyoss/dragonfly` | Go | All versions | 2.1.0 |
| `d7y.io/dragonfly/v2` | Go | All versions | 2.1.0 |
| `d7y.io/dragonfly/v2` | Go | All versions | 2.1.0 |
| `d7y.io/dragonfly/v2` | Go | All versions | 2.1.0 |

Products: Linuxfoundation Dragonfly.

## How do I fix CVE-2025-59410?

Upgrade github.com/dragonflyoss/dragonfly to 2.1.0 or later.

## Is CVE-2025-59410 being exploited?

There is no known exploitation of CVE-2025-59410 in the wild and no public exploit code.

## Other vulnerabilities in dragonflyoss dragonfly

- [CVE-2023-27584](https://insights.sbomify.com/CVE-2023-27584/): Dragonfly2 vulnerable to hard coded cyptographic key (critical 9.8)
- [CVE-2026-24124](https://insights.sbomify.com/CVE-2026-24124/): Dragonfly Manager Job API Allows Unauthenticated Access (high 8.9)
- [CVE-2025-59345](https://insights.sbomify.com/CVE-2025-59345/): Dragonfly did not enable authentication for some Manager’s endpoints (high 7.7)
- [CVE-2025-59353](https://insights.sbomify.com/CVE-2025-59353/): Manager generates mTLS certificates for arbitrary IP addresses (high 7.7)
- [CVE-2025-59352](https://insights.sbomify.com/CVE-2025-59352/): Dragonfly allows arbitrary file read and write on a peer machine (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59410 and fix it if it is affected.

What it is: CVE-2025-59410 is a medium-severity vulnerability in dragonflyoss dragonfly, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-59410 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dragonflyoss/dragonfly (Go): affected all versions; no fix listed
- github.com/dragonflyoss/dragonfly (Go): affected all versions; fixed in 2.1.0
- github.com/dragonflyoss/dragonfly (Go): affected all versions; fixed in 2.1.0
- d7y.io/dragonfly/v2 (Go): affected all versions; fixed in 2.1.0
- d7y.io/dragonfly/v2 (Go): affected all versions; fixed in 2.1.0
- d7y.io/dragonfly/v2 (Go): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59410/ (Markdown: https://insights.sbomify.com/CVE-2025-59410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59410
- OSV: https://osv.dev/vulnerability/CVE-2025-59410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59410/
Summaries are generated and may contain mistakes; the official description above is the record.
