# CVE-2025-59411: CubeCart Stored/Reflected HTML Injection Vulnerability in Contact Enquiry

> Attackers can inject malicious HTML into contact forms, potentially executing scripts in admin email clients or interfaces, requiring an upgrade to CubeCart.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-5hg3-m3q3-v2p4

## What is CVE-2025-59411?

CVE-2025-59411 is a medium-severity cross-site scripting vulnerability in cubecart v6, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CubeCart is an ecommerce software solution. Prior to version 6.5.11, the contact form’s Enquiry field accepts raw HTML and that HTML is included verbatim in the email sent to the store admin. By submitting HTML in the Enquiry, the admin receives an email containing that HTML. This indicates user input is not being escaped or sanitized before being output in email (and possibly when re-rendering the form), leading to Cross-Site Scripting / HTML injection risk in email clients or admin UI. This issue has been patched in version 6.5.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59411?

It affects 1 product.


Products: Cubecart Cubecart.

## How do I fix CVE-2025-59411?

No fix has been published for CVE-2025-59411 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59411 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59411 exists.

## Other vulnerabilities in cubecart v6

- [CVE-2024-34832](https://insights.sbomify.com/CVE-2024-34832/): Path traversal in n/a (critical 9.8)
- [CVE-2018-20716](https://insights.sbomify.com/CVE-2018-20716/): SQL injection in n/a (critical 9.8)
- [CVE-2013-1465](https://insights.sbomify.com/CVE-2013-1465/): Deserialization in n/a (critical 9.8)
- [CVE-2026-21719](https://insights.sbomify.com/CVE-2026-21719/): Command injection in CubeCart (high 8.6)
- [CVE-2023-38130](https://insights.sbomify.com/CVE-2023-38130/): Cross-site request forgery in CubeCart (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59411 and fix it if it is affected.

What it is: CVE-2025-59411 is a medium-severity cross-site scripting vulnerability in cubecart v6, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59411 exists.

Affected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59411/ (Markdown: https://insights.sbomify.com/CVE-2025-59411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59411
- OSV: https://osv.dev/vulnerability/CVE-2025-59411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59411/
Summaries are generated and may contain mistakes; the official description above is the record.
