# CVE-2025-59414: Nuxt Client-Side Path Traversal in Nuxt Island Payload Revival

> Attackers can manipulate client-side requests to access different endpoints within the same domain via path traversal in Nuxt Island payload revival.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2025
- **Updated:** 17 Sep 2025
- **Also known as:** CLSA-2026-1775867597, CLSA-2026-1792161442, CLSA-2026-1792161481, CLSA-2026-1792161582, CLSA-2026-1792161806, CLSA-2026-1792161919, GHSA-p6jq-8vc4-79f6

## What is CVE-2025-59414?

CVE-2025-59414 is a low-severity path traversal vulnerability in nuxt, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nuxt is an open-source web development framework for Vue.js. Prior to 3.19.0 and 4.1.0, A client-side path traversal vulnerability in Nuxt's Island payload revival mechanism allowed attackers to manipulate client-side requests to different endpoints within the same application domain when specific prerendering conditions are met. The vulnerability occurs in the client-side payload revival process (revive-payload.client.ts) where Nuxt Islands are automatically fetched when encountering serialized __nuxt_island objects. During prerendering, if an API endpoint returns user-controlled data containing a crafted __nuxt_island object, he data gets serialized with devalue.stringify and stored in the prerendered page. When a client navigates to the prerendered page, devalue.parse deserializes the payload. The Island reviver attempts to fetch /__nuxt_island/${key}.json where key could contain path traversal sequences. Update to Nuxt 3.19.0+ or 4.1.0+.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-59414?

4 open source packages ship an affected version, including nuxt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt` | npm | From 3.6.0 | 3.19.0 |
| `nuxt` | npm | From 3.6.0 | 3.19.0 |
| `nuxt` | npm | From 4.0.0 | 4.1.0 |
| `nuxt` | npm | From 4.0.0 | 4.1.0 |

Products: Nuxt Nuxt.

## How do I fix CVE-2025-59414?

Upgrade nuxt to a fixed version for your release line: 3.19.0 or 4.1.0.

## Is CVE-2025-59414 being exploited?

There is no known exploitation of CVE-2025-59414 in the wild and no public exploit code.

## Other vulnerabilities in nuxt

- [CVE-2026-53721](https://insights.sbomify.com/CVE-2026-53721/): Nuxt: Route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher (high 8.8)
- [CVE-2024-23657](https://insights.sbomify.com/CVE-2024-23657/): Path Traversal: '../filedir' in Nuxt Devtools (high 8.8)
- [CVE-2024-34344](https://insights.sbomify.com/CVE-2024-34344/): Remote code execution via the browser when running the test locally in nuxt (high 8.8)
- [CVE-2024-42352](https://insights.sbomify.com/CVE-2024-42352/): Server-Side Request Forgery (SSRF) in nuxt-icon (high 8.6)
- [CVE-2023-3224](https://insights.sbomify.com/CVE-2023-3224/): Code Injection in nuxt/nuxt (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59414 and fix it if it is affected.

What it is: CVE-2025-59414 is a low-severity path traversal vulnerability in nuxt, published on 17 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59414 in the wild and no public exploit code.

Affected packages and fixed versions:
- nuxt (npm): affected from 3.6.0; fixed in 3.19.0
- nuxt (npm): affected from 3.6.0; fixed in 3.19.0
- nuxt (npm): affected from 4.0.0; fixed in 4.1.0
- nuxt (npm): affected from 4.0.0; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59414/ (Markdown: https://insights.sbomify.com/CVE-2025-59414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59414
- OSV: https://osv.dev/vulnerability/CVE-2025-59414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59414/
Summaries are generated and may contain mistakes; the official description above is the record.
