{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59417 exists.","fix":"Upgrade @lobehub/chat to 1.129.4 or later.","what":"CVE-2025-59417 is a medium-severity cross-site scripting vulnerability in lobehub lobe-chat, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59417 and fix it if it is affected.\n\nWhat it is: CVE-2025-59417 is a medium-severity cross-site scripting vulnerability in lobehub lobe-chat, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59417 exists.\n\nAffected packages and fixed versions:\n- @lobehub/chat (npm): affected all versions; fixed in 1.129.4\n- @lobehub/chat (npm): affected all versions; fixed in 1.129.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59417/ (Markdown: https://insights.sbomify.com/CVE-2025-59417/index.md)","id":"CVE-2025-59417","markdown":"https://insights.sbomify.com/CVE-2025-59417/index.md","name":"CVE-2025-59417","record":{"aliases":["GHSA-m79r-r765-5f9j"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Lobe Chat Desktop","requires_auth":"none","summary":"Attackers can achieve remote code execution on user machines via XSS in chat messages rendered as SVG, requiring an upgrade to Lobe Chat.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lobe_chat","vendor":"lobehub"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like \u003clobeArtifact identifier=\"ai-new-interpretation\" ...\u003e , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages","id":"CVE-2025-59417","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"BunnyPad Vulnerable to Buffer Overflow When Opening Files of Size 20MB or Greater","id":"CVE-2025-59418"},"packages":[{"ecosystem":"npm","fixed":["1.129.4"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":null,"source":"GHSA-m79r-r765-5f9j"},{"ecosystem":"npm","fixed":["1.129.4"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":"pkg:npm/%40lobehub/chat","source":"GHSA-m79r-r765-5f9j"}],"prev":{"headline":"The Scratch Channel forks can publish articles","id":"CVE-2025-59416"},"products":["lobe-chat"],"published":"2025-09-18","related":[{"cvss_score":9,"headline":"Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)","id":"CVE-2024-47066","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9,"headline":"lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability","id":"CVE-2024-32964","kev_date_added":null,"published":"2024-05-10"},{"cvss_score":8.1,"headline":"ssrf vulnerability in lobe-chat","id":"CVE-2024-32965","kev_date_added":null,"published":"2024-11-26"},{"cvss_score":5.7,"headline":"API Key Leak in lobe-chat","id":"CVE-2024-37895","kev_date_added":null,"published":"2024-06-17"},{"cvss_score":5.3,"headline":"Lobe Chat unauthorized access to plugins","id":"CVE-2024-24566","kev_date_added":null,"published":"2024-01-31"},{"cvss_score":4.3,"headline":"lobe-chat has an Open Redirect","id":"CVE-2025-59426","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-19","vendors":["lobehub"]},"summary":"Attackers can achieve remote code execution on user machines via XSS in chat messages rendered as SVG, requiring an upgrade to Lobe Chat.","url":"https://insights.sbomify.com/CVE-2025-59417/"}