# CVE-2025-59417: Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages

> Attackers can achieve remote code execution on user machines via XSS in chat messages rendered as SVG, requiring an upgrade to Lobe Chat.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Sep 2025
- **Updated:** 19 Sep 2025
- **Also known as:** GHSA-m79r-r765-5f9j

## What is CVE-2025-59417?

CVE-2025-59417 is a medium-severity cross-site scripting vulnerability in lobehub lobe-chat, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ...> , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-59417?

2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/chat` | npm | All versions | 1.129.4 |
| `@lobehub/chat` | npm | All versions | 1.129.4 |

Products: Lobehub Lobe Chat.

## How do I fix CVE-2025-59417?

Upgrade @lobehub/chat to 1.129.4 or later.

## Is CVE-2025-59417 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59417 exists.

## Other vulnerabilities in lobehub lobe-chat

- [CVE-2024-47066](https://insights.sbomify.com/CVE-2024-47066/): Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) (critical 9.0)
- [CVE-2024-32964](https://insights.sbomify.com/CVE-2024-32964/): lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability (critical 9.0)
- [CVE-2024-32965](https://insights.sbomify.com/CVE-2024-32965/): ssrf vulnerability in lobe-chat (high 8.1)
- [CVE-2024-37895](https://insights.sbomify.com/CVE-2024-37895/): API Key Leak in lobe-chat (medium 5.7)
- [CVE-2024-24566](https://insights.sbomify.com/CVE-2024-24566/): Lobe Chat unauthorized access to plugins (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59417 and fix it if it is affected.

What it is: CVE-2025-59417 is a medium-severity cross-site scripting vulnerability in lobehub lobe-chat, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-59417 exists.

Affected packages and fixed versions:
- @lobehub/chat (npm): affected all versions; fixed in 1.129.4
- @lobehub/chat (npm): affected all versions; fixed in 1.129.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59417/ (Markdown: https://insights.sbomify.com/CVE-2025-59417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59417
- OSV: https://osv.dev/vulnerability/CVE-2025-59417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59417/
Summaries are generated and may contain mistakes; the official description above is the record.
