{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-59418 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-59418 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-59418 is a medium-severity memory corruption vulnerability in GSYT-Productions BunnyPad-SRC, published on 22 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-59418 and fix it if it is affected.\n\nWhat it is: CVE-2025-59418 is a medium-severity memory corruption vulnerability in GSYT-Productions BunnyPad-SRC, published on 22 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-59418 in the wild and no public exploit code.\n\nAffected product: GSYT-Productions BunnyPad-SRC. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-59418/ (Markdown: https://insights.sbomify.com/CVE-2025-59418/index.md)","id":"CVE-2025-59418","markdown":"https://insights.sbomify.com/CVE-2025-59418/index.md","name":"CVE-2025-59418","record":{"aliases":["GHSA-qhw4-c7x5-vxmj"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"BunnyPad note taking","requires_auth":"none","summary":"Attackers can trigger a buffer overflow in BunnyPad by providing large files, potentially leading to code execution or crashes.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"BunnyPad is a note taking software. Prior to version 11.0.27000.0915, opening files greater than or equal to 20MB causes buffer overflow to occur. This issue has been patched in version 11.0.27000.0915. Users who wish not to upgrade should refrain from opening files larger than 10MB.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"BunnyPad Vulnerable to Buffer Overflow When Opening Files of Size 20MB or Greater","id":"CVE-2025-59418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery","id":"CVE-2025-59419"},"packages":[],"prev":{"headline":"Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages","id":"CVE-2025-59417"},"products":["BunnyPad-SRC"],"published":"2025-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-22","vendors":["GSYT-Productions"]},"summary":"Attackers can trigger a buffer overflow in BunnyPad by providing large files, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2025-59418/"}