# CVE-2025-59418: BunnyPad Vulnerable to Buffer Overflow When Opening Files of Size 20MB or Greater

> Attackers can trigger a buffer overflow in BunnyPad by providing large files, potentially leading to code execution or crashes.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Sep 2025
- **Updated:** 22 Sep 2025
- **Also known as:** GHSA-qhw4-c7x5-vxmj

## What is CVE-2025-59418?

CVE-2025-59418 is a medium-severity memory corruption vulnerability in GSYT-Productions BunnyPad-SRC, published on 22 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

BunnyPad is a note taking software. Prior to version 11.0.27000.0915, opening files greater than or equal to 20MB causes buffer overflow to occur. This issue has been patched in version 11.0.27000.0915. Users who wish not to upgrade should refrain from opening files larger than 10MB.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-59418?


## How do I fix CVE-2025-59418?

No fix has been published for CVE-2025-59418 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-59418 being exploited?

There is no known exploitation of CVE-2025-59418 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-59418 and fix it if it is affected.

What it is: CVE-2025-59418 is a medium-severity memory corruption vulnerability in GSYT-Productions BunnyPad-SRC, published on 22 Sep 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-59418 in the wild and no public exploit code.

Affected product: GSYT-Productions BunnyPad-SRC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-59418/ (Markdown: https://insights.sbomify.com/CVE-2025-59418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-59418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-59418
- OSV: https://osv.dev/vulnerability/CVE-2025-59418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-59418/
Summaries are generated and may contain mistakes; the official description above is the record.
